Lost 5k in windows, driver is gone??

Discussion in 'Windows, Linux & Others on the Mac' started by iemcj, Dec 16, 2015.

  1. iemcj, Dec 16, 2015
    Last edited: Dec 16, 2015

    iemcj macrumors 6502

    iemcj

    Joined:
    Oct 31, 2015
    #1
    So I somehow lost 5k support in windows. I was in the catalyst control center and somehow activated something to do with multi screen. It made the resolution all distorted on my screen so I tried to revert it and all seemed well. Then i noticed all my icons were a little larger… Hmm, odd.

    I go to the “advanced display settings” in windows and holy cow, i’m only running at 3840x2160! And it is greyed out and i can’t change it! I click lower down on “display adapter properties” and it just says “microsoft basic display adapter” What the heck??

    I right click the desktop to get to the AMD Catalyst control center and it’s very bare bones, it has no area for me to even adjust ANYTHING with the display, it’s just gone. When I go to update the software under current version it says “not installed.” Does anyone know how to fix this?? D:

    Just tried to load a game... dear god. I went from 55 fps in witcher 3 to about 14 at the loading screen.
     
  2. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #2
    You could try uninstalling the graphics driver in Device Manager and then scanning for hardware changes to see if it finds and re-installs the right driver package.
     
  3. iemcj thread starter macrumors 6502

    iemcj

    Joined:
    Oct 31, 2015

Share This Page