Lost Ability to Write/Burn Disks with Mojave

Discussion in 'macOS Mojave (10.14)' started by fled2fla, Oct 28, 2018.

Tags:
  1. fled2fla macrumors newbie

    Joined:
    Oct 28, 2018
    #1
    I have late 2014 Mac. Also have a Samsung USB drive to read/burn CDs, DVDs, and Blu-Ray. I regularly burn disks for a variety of reasons. Upgraded two weeks ago to Mojave (10.14) - final version, not a beta. All of a sudden, I lost my ability to burn disks. It was working a day earlier on 10.13.xx.

    When I put a disk in, I get the normal pop-up saying new disk and I clicked through it. In the past, after that it would give me a disk icon on my desktop. I could then title the disk and drop the folders I wanted to copy onto it. Then drag to trash and it burns.

    Since installing 10.14, I put the disk in, get the pop-up and click through it. It does not show a disk icon on my desktop nor in the Finder sidebar. (It does show up at a lower level, under the name of MacPro (my computer name), next to Macintosh HD and Network. It won't let me copy stuff over to the folder nor let me burn the disk. In fact, I have to restart the computer to get the disk physically out.

    Since it was working the day before and I'm using the same blank disks (and have tried a couple of different disks), I'm blaming my upgrade to 10.14. Any suggestions / help / fixes or can someone tell me how to back up to 10.13? (I do not use Time Machine)
     
  2. chabig macrumors 603

    Joined:
    Sep 6, 2002
    #2
    Check your Finder preferences, both General and Sidebar.
    What happens when you try? What kind of error do you get?
    You should be able to right click on the disk icon and select "Eject..."
     
  3. Dc2006ster macrumors regular

    Joined:
    Jun 9, 2011
    Location:
    Alberta, Canada
    #3
    My Finder Preferences are set to show CDs, DVDs and iPods in the Sidebar and on the Desktop but, like you, blank CDs do not show up in either of those places. They do however show in Disk Utility and can be ejected from there. CDs and DVDs that I have previously burned do show up and can be ejected normally.

    I made a folder of files to burn and was able to do so by right clicking on that folder and choosing Burn ... to Disc from the contextual menu. The burned disc then showed up on the Desktop and in the Sidebar. Not sure if this is of much help to you but at least it shows that burning can be done in Mojave. My burner is a cheap one purchased from Amazon. If yours does not burn discs perhaps the problem is with the burner itself.

    I did a clean install of Mojave and then had to setup my Finder Preferences to show CDs etc. and and Mouse Preferences to activate the right click for contextual menus.
     
  4. chabig macrumors 603

    Joined:
    Sep 6, 2002
    #4
    It's also possible that third party drives might require driver updates.
     
  5. StralyanPithecus macrumors regular

    StralyanPithecus

    Joined:
    Sep 27, 2018
    #5
    I just checked, clean Mojave install using external usb dvd-rw unit, at the beginning finder asks what to do with the disk, default is open with finder, but after that nothing happens, just opens the finder with any mention of the CD, checked all finder settings, browsing through my MacBook Pro is only the network remote cd disk. But using Burn app from http://burn-osx.sourceforge.net it detects the driver and the disk inside correctly. Under disk utility the DVD appears but no options there, just create an image from the DVD and eject the disk inside the unit.
     
  6. fled2fla, Oct 28, 2018
    Last edited: Oct 28, 2018

    fled2fla thread starter macrumors newbie

    Joined:
    Oct 28, 2018
    #6
    Thanks for all the quick responses.

    Let me answer Chabig's 1st post: When I try to drop a file or folder onto the disk for copying (and eventual burning), I get a message "Modifying "Remote Disk" requires an administrator name and password. To move "filename" click authenticate." Well, I'm the administrator of my own computer and I don't want to move files or folders, I want to copy them (on 10.13, it would be an alias to the file if you looked at the disk icon).
    Also I tried using the option and command keys in conjunction with the disk eject in the upper right part of the keyboard but it does not eject the disk.

    Also I've never needed a driver for this disk drive before - either on this computer or on a laptop which I occasionally used (got rid of the laptop a few months ago when the battery went).

    To Dc2006ster: my finder preferences are set to show disks in the sidebar.

    (will follow up on other comments later today)
    --- Post Merged, Oct 28, 2018 ---
    One more thing I just tried: when I go to Disk Utility, it shows up as an external drive - TSSTcorpBDDVD.......

    If I do a File / Eject, the disk does come out (saves me the trouble of a restart at least)
    --- Post Merged, Oct 28, 2018 ---
    Just tried something else based on the responses so far: I set up a burn folder, put in a couple of files, and hit the Burn button. It seemed to work. So there is a way to burn the discs, just not as simple as before.
     

Share This Page

5 October 28, 2018