Lost Car Head Unit Music Functionality on iOS11

Discussion in 'iOS 11' started by nasa25, Jun 9, 2017.

  1. nasa25 macrumors 65816

    Joined:
    Apr 11, 2010
    Location:
    canada
    #1
    Has anyone been having trouble controlling music from their car's infotainment system after installing the beta?

    I used to be able to see my playlist, choose songs and control them through my cars infotainment system....I can still see my playlist and music library, but clicking on a song does nothing. I can still however control music through my iPhone and it will play over my cars stereo system.

    Anyone having issues controlling music through their infotainment system?

    FYI the vehicle in question is a 2009 XF. Setup was working perfectly on 10.3.2....
     
  2. BBDDVV macrumors newbie

    Joined:
    Oct 30, 2014
    #2
    I have exactly this but it's in 10.3.3 beta 2... This was working fine in 10.3.3 beta 1 and earlier...
     
  3. nasa25 thread starter macrumors 65816

    Joined:
    Apr 11, 2010
    Location:
    canada
    #3
    ah that sucks. I'm planning to send my feedback to Apple and hopefully enough people have the issue to cause them to fix it. At least everything else is working great for me on iOS11 lol.
     
  4. BBDDVV, Jun 9, 2017
    Last edited: Jun 16, 2017

    BBDDVV macrumors newbie

    Joined:
    Oct 30, 2014
    #4
    I also reported the issue, can't see how this would not be fixed :)
     
  5. BBDDVV macrumors newbie

    Joined:
    Oct 30, 2014
    #5
    It works fine again in 10.3.3 beta 3! :)
     
  6. CloudSpeaker macrumors newbie

    CloudSpeaker

    Joined:
    Sep 26, 2016
    Location:
    Not Quite Phoenix
    #6
    CarPlay hasn't worked for me ('16 Honda Accord) since 10.3. Tried multiple phones. Same deal. Hoping iOS 11 fixes this.
     
  7. nasa25 thread starter macrumors 65816

    Joined:
    Apr 11, 2010
    Location:
    canada
    #7
    So same issue under beta 3. If I click on a song on my iPhone (connected via a viseo tune2air to my head unit) the song plays without issue and I have full playback control via my steering wheel

    If I try to select a song through my car's head unit, nothing happens. The playback starts on the iPhone (song counter starts to go) but the music isn't going through my viseo tune2air to the car's speakers.

    Weird af problem
     
  8. nasa25 thread starter macrumors 65816

    Joined:
    Apr 11, 2010
    Location:
    canada
    #8
    hmmm guess I'm the only one with the problem

    figured more people would have an iPhone and a car.
     
  9. Bobout macrumors member

    Bobout

    Joined:
    Apr 6, 2017
    Location:
    Socal
    #9
    I actually finally get my contact pics to show up on my 14 tundra on ios 11 and on 10.3.3 it didn't work but i lost my album art on ios 11 so i guess its a trade off :rolleyes:
     
  10. nasa25 thread starter macrumors 65816

    Joined:
    Apr 11, 2010
    Location:
    canada
    #10
    I’d be happy to just be able to play music lol
     
  11. gh2k macrumors newbie

    Joined:
    Jan 11, 2016
    #11
    My car 2012 Chevy Equinox will work sometimes but sometimes not, I am still trying to figure out if it is a car issue or phone issue. It started getting weird with 10.3.3 beta, now in 11 it won't load the album art or the song titles half the time. I can control it but it just says song 1. After a bit sometimes it loads up with titles. I tried carplay in a 2017 Buick LaCrosse I had as a loaner from the dealership the other day and it worked perfectly with PB2.

    I have been trying to nail down the steps to reproduce the error because sometimes it connects to the car no problem and other times it is a no go.
     

Share This Page