lost connection to my router

Discussion in 'MacBook Pro' started by gnozu, Mar 15, 2007.

  1. gnozu macrumors newbie

    Mar 15, 2007

    The other day I turned on my MacBook (only 2 months old) and I couldn't connect to my wireless router. It's a DLink G604T with updated firmware, WPA encryption, and works fine with all the Windows PC in my home. I now get the standard "cannot connect to..." error each time I try to connect to the network, either with WEP or WPA. No encryption, and I can connect no problem at all.

    The previous day I'd installed Apple's 2007-002 update. Apple suggested reinstalling the OS and not installing that update. This had exactly no effect whatsoever.
    I've also tried resetting the router to default settings and starting over, different passwords, different channels. So, it's not the router (works with PCs), it's not the OS (reinstalled), it's not the hardware (works without WEP and WPA)... I'm completely at a loss...

    Does anyone have any idea what the problem might be?
  2. ericssonboi macrumors 6502

    Mar 15, 2005
    I think the same thing happened on my Dlink DI-624. Even after reboot, it wouldn't connect however i was able to connect to other Linksys routers earlier in the day. What I did was basicly just change settings on the Wireless Network. Log into the Settings Page of the router and I changed my network name and the password. I use WPA-SSK. After doing that everything has been working fine.
  3. gnozu thread starter macrumors newbie

    Mar 15, 2007
    ok thanks, I'll try that. Failing that I guess the only other option is to buy a new router - my Dlink has been a bit hit and miss generally over the last couple of years anyway.
  4. ericssonboi macrumors 6502

    Mar 15, 2005
    Shouldn't be an issue.. the same thing crossed my mind last night how maybe its time to buy a new router...
    However, when i wired in to the router, I had no issues connecting.

    It should be some kind of connection issue.. I was about to reset all settings on the router (hard reset) .. but before I did.. i just changed the Network ID and password to make it seem like i'm connecting to a new network. Its been working since but connect signal has dropped even though my MBP was right beside the router.
  5. TraceyS/FL macrumors 601

    Jan 11, 2007
    North Central Florida
    UGH. Welcome to the nightmere of the last 2 weeks around here.

    We moved onto a Belkin N-1 (from TWO D-Links that I don't know the models of off hand). That now has the MacPro not being able to see the Apple Talk printers (85 minutes on the phone with Apple yesterday).

    One thing I noticed was that while I was connected to the router, my Airport would start losing the connection - when I opened Internet Connect it said, "Your airport has assigned itself and IP address and you may not be able to connect to the internet". Sure enough....

    It hasnt' done it since i've been home though (was out of town for the weekend), so i don't know if jumping on someone else's wireless "fixed it" or not.

    My Mom is on her way to go buy the Apple Router though - the solution for the N-1 is to turn off NAT (convert the router into a Bridge). The N-1 runs way hot - so we think it has it's own issues. At this point, we will just bite the bullet and hope the Apple one fixes the issue. The printers worked fine with the D-Links - we just couldn't stay connected to them.

    Of course, there are cases where computers are still having the issues we are on the MacPro - but apparently it's SOOOO random that they can't troubleshoot and write a patch for it. Great.

    But, i feel your pain.......
  6. chris315 macrumors newbie

    Sep 4, 2006
    im having the same problem with my mbp and my dlink router, at least im not the only 1
  7. apachie2k macrumors 6502


    May 23, 2006
    was NYC...now MIAMI
    sometimes passwords on macs for some reason need a $ sign bfore the actuall password....worked for me, try it!!!
  8. TraceyS/FL macrumors 601

    Jan 11, 2007
    North Central Florida

    Got the Apple Extreme N hooked up. All is well in the world... the printers work, the computers work that are hardwired via an Ethernet Hub we have hanging off of it work, the wireless Macs (all 4 - 2-n 2-g) work.

    Not the cheapest solution - but after a week of H*&&, i'll take it!

    We did the firmware upgrade to the d-link 624 - and nothing worked right since then, so if you did that - call dlink (only M-F though) to find out how to reset that (i spent 2 hours on the phone on a weekend - only to be told i had to call back monday after 8 to talk to a level 2 tech. NOT. We went and bought the Belkin N1).

    I've seriously now lost track of everything we have been thru - but i can right now with the Apple Extreme, the Macs, Network Printers and XP machines are all happy. Life is good again - I need a break from it!
  9. chris315 macrumors newbie

    Sep 4, 2006
    looks like im goin to have to buy the extreme n then
  10. ericssonboi macrumors 6502

    Mar 15, 2005
    I really don't think its neceassary to buy a new router just cause it won't connect.

    You have to figure out which part isn't working..
  11. TraceyS/FL macrumors 601

    Jan 11, 2007
    North Central Florida
    I agree - BUT, in our case, we were pretty sure dLink #1 had taken a pretty ninja power hit/cable hit when we had that pesky Tornado touch down in the front yard 2/2. So we couldn't trust the connection issues we were having weren't from that. We had dlink #2 laying around - it was faster, but hadnt' been running it because of some funky compatibility/range issues. So no money to try it. When it had issues - and I spent that 2 hours on the phone with their Tech Support Saturday night - after having MAJOR ISSUES after upgrading the firmware - only to be told they could do NOTHING for me until 8am monday morning (at that point i could run only open - like I wanted to be the wireless host for the neighborhood for the rest of the weekend).

    That was unacceptabile - so we bought the Belkin N1 because it was the only option we had locally. We are an hour from the Apple store, or we would have just bought that to start with.

    The Belkin ran great - until we enabled Mac address restrictions. It freaked the network - no computers wireless OR hardwired could get on it. Factory reset cleared that up. Never tried Mac addy's again.

    1 Mac couldn't see any of the Appletalk printers - the other THREE could just fine. We were dealing with that issue until I returned from a trip. Friday we lost the ability to log into the router. We have no clue what happened - but the thing ran HOT - enough that when you walked by it there was a heat cloud. A factory reset again fixed the issue and we reset all our settings.

    I called Apple on the printers not showing - 85 minutes on the phone for that, leaving me with ONLY option being changing the Router into a Bridge. Which impacted other stuff on the net and really wasn't an acceptable solution. Apple didn't feel it was a software issue at all - that the problem was in the router. Whether it was the exact combination of the Router and the Airport card in the MacPro - we will never know.

    I didn't do ANYTHING today except replace the router. No software changes on the MacPro, and all of a sudden it could see the AppleTalk printers like the other 3 Macs in the house.

    Go figure.

    Apple has cases of the same problem WITH the Airport Extreme (they solve it by doing the bridge thing). He indicated that they don't have enough of them to create a solution for it. Hence the direction I needed to go to TRY to solve it.

    So in this case - the problem was obviously THE ROUTER. Maybe it could have been fixed - I don't know, but i'm 1.5 weeks into this "problem" and over it. I own a Mac because it "just works" (i had enough of these issues back in my working Network Admin career). And this didn't.

    Now it does.

    Knowing others are having issues with similar hardware - Intel with N, dLink and such is always helpful.

    I wish the posters the best of luck.... it's a pain to troubleshoot.


    PS - for the record the computers involved...

    eMac G4, 1.25mhz, 10.4.8 - fine
    iBook G4, 800mhs, 10.4.8 - fine
    MacBook Pro, C2D 2.33, 10.4.8 - fine for printers, random drops with dlink & Belkin (2/2007 build, N enabled)
    MacPro, C2d, Stock, 10.4.8 - issues. Connect fine, no printers (12/2006 build, N enabled)

    Vaio - hardwired, variety of issues.
  12. gnozu thread starter macrumors newbie

    Mar 15, 2007
    ok thanks for the tip about changing the router's SSID. I *finally* got my macbook connected to the network, but only after changing SSID and channel number. Somehow changing both separately didn't work, but doing both did work.
    Completely mad...
  13. TraceyS/FL macrumors 601

    Jan 11, 2007
    North Central Florida
    YAY!! Here is hoping it stays connected now!!
  14. ericssonboi macrumors 6502

    Mar 15, 2005
    For anyone still having issues..

    I changed my network SSID the other day... worked perfectly... left the house, connected to another wifi network.. when i came back, it wouldn't connect to the network again.

    When i wired into the router, everything worked fine.

    So back to router settings.. I updated the firmware on my DI-624 and changed the SSID and password to the network again.. and now everything is working again..

    Buying a new router would be the easy fix.. but i'd rather spend it on a new computer rather than a router that is just conflicting..

    I hope Apple releases a fix for it.. as a few ppl are having this issue whereas everything was working fine before the update..
  15. TraceyS/FL macrumors 601

    Jan 11, 2007
    North Central Florida
    I hope it sticks this time - we had that horrid experience with that firmware upgrade on the 624. I'm afraid of them now! LOL!!

    Heck, i'm worried about trying Parallels again - even though the router change might have fixed the issues i was having. But i'm afraid....
  16. mcanadiensfan71 macrumors newbie

    Mar 14, 2007
    this happened to me also. What i did was that when it asks you for the password of the router, it has like 3 different password types. try all 3 of those types. it worked for me, I thought the pasword was a WEP but it turned out to be a WAP 400x600 or something like that

Share This Page