Lost ethernet with macOS Sierra

Discussion in 'macOS Sierra (10.12)' started by GMan71, Sep 12, 2016.

  1. GMan71 macrumors newbie

    Joined:
    Jun 28, 2010
    #1
    I installed the macOS Sierra GM candidate last Friday and now I can't seem to access the internet through my ethernet connection. The WiFi is working fine. Has anyone else experienced this issue?
     
  2. farleyruskz macrumors newbie

    Joined:
    Sep 14, 2007
    #2
    Yes, this happened to me with my Thunderbolt to Ethernet connection. I was able to fix it by going into the Network panel of System Preferences, deleting the Ethernet interface from the list on the left, and rebooting. After the reboot the Ethernet interface came back and was working.
     
  3. mmomega macrumors demi-god

    mmomega

    Joined:
    Dec 30, 2009
    Location:
    DFW, TX
    #3
    I haven't yet.
    I have 3 different Macs - a 2012 Mini, a 2013 Mac Pro and a 2015 iMac - all connected via ethernet with the Mac Pro using both ethernet port and I have not noticed a drop or disconnect yet.
     
  4. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #4
    My Mac Pro is ethernet only and no Wi-Fi, no problem at all, fast and stable connection.
     
  5. GMan71 thread starter macrumors newbie

    Joined:
    Jun 28, 2010
    #5
    I tried what farleyruskz suggested, but that didn't work for me. I'm going to try a different ethernet cable to see if that does any good. It's strange that this only started happening when I upgraded to MacOS Sierra.
     
  6. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #6
    Did you check the details in the system preference? Do they make sense? Did you check the firewall?
     
  7. ssls6 macrumors 6502a

    ssls6

    Joined:
    Feb 7, 2013
    #7
    Look at the service order and make sure ethernet is higher than wifi
     
  8. GMan71 thread starter macrumors newbie

    Joined:
    Jun 28, 2010
    #8
    I did see a message in the System Information menu that said something about "Incompatible Kernel Extension Configuration Data" that was dated the same day that I installed the update. It looks like there was a software update issued earlier this year by Apple that resulted in the same problem with ethernet connections on Macs.
    --- Post Merged, Sep 13, 2016 ---
    I tried that too.
     
  9. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #9
    1. Be prepared to enter your administrator password
    2. launch Terminal
    3. enter the command below
    4. copy the output
    5. share the output here.
    sudo kextstat | grep -v com.apple

    Hint: use the '+' Insert… menu to paste as code
     
  10. d0nbx macrumors newbie

    d0nbx

    Joined:
    Sep 21, 2016
    #10
    --- Post Merged, Sep 21, 2016 ---
    can someone help with this? I have the same problem.. ethernet is not even showing up as an option in the network preferences?
    see network preferences here:
    https://goo.gl/QHbyiN
    there are the add menu options:
    https://goo.gl/isSgBH

    no ethernet there?

    I am using this 3 port usb 3.0 and ethernet adapter:
    https://www.amazon.com/gp/product/B00EHDNAOE/ref=oh_aui_search_detailpage?ie=UTF8&psc=1


    here is the terminal log:
    "
    Last login: Wed Sep 21 13:26:43 on console

    MacBook-Pro:~ Daniel$ sudo kextstat | grep -v com.apple

    Password:

    Index Refs Address Size Wired Name (Version) UUID <Linked Against>

    23 0 0xffffff7f80f92000 0x43000 0x43000 com.logitech.manager.kernel.driver (6.20.1) F1C82D62-BFA1-3A21-A831-E51477241CB8 <22 19 18 16 5 4 3>

    145 0 0xffffff7f81158000 0x4000 0x4000 com.globaldelight.driver.Boom2Device (1.1) 7F7523A6-5BE4-3452-9713-BBC88EA4BED3 <113 5 4 3 1>

    146 0 0xffffff7f80a34000 0x5000 0x5000 com.techsmith.TACC (1.0.3) 851BEDD1-1D12-3756-A948-978610078DEF <5 4 3>
    "

    I also use a VPN
     
  11. Lokii44 macrumors newbie

    Joined:
    Sep 22, 2016
    #11
    Same issue. And frustratingly, network diagnostics shows everything "green" and says my internet appears to be working fine!

    Have rebooted everything (iMac, Time Machine and cable modem), reset PRAM, turned firewall off, changed DNS and re-upped DHCP. Nada. Even tried different cables and Ethernet ports.

    All the other devices in the house using WiFi can get out.

    As a last resort I even tried to use my iPhone as a mobile hotspot and the iMac couldn't use that connection to get out to the Internet! Sierra really screwed things up, so it's beyond just Ethernet.... Am restoring back to El Cap for a while.
     
  12. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #12
    Are any of you folks having this issue running any proxy or AV software packages? Often OS updates will cause a conflict with these "Internet security suite" packages and block access. Try a reboot to safe mode by holding the shift key at boot. That will stop all third party utilities and apps from launching. If that fixes it, the run an Etrecheck report to ID the launch or startup item causing this.
     
  13. Lokii44 macrumors newbie

    Joined:
    Sep 22, 2016
    #13
    No 3rd party apps or security suites running.

    Restored to El Capitan via Time machine backup and all is working again...
     
  14. T4T macrumors newbie

    Joined:
    Sep 26, 2016
    #14
    For a workaround that worked for me, see:
    https://discussions.apple.com/thread/7675928?start=0&tstart=0

    See emilstahl's entry.

    You need to:
    • restart into Recovery OS (restart, hold cmd-R until the Apple logo appears)
    • bring up "Terminal" in "Utilities" menu (do NOT click anything in the window)
    • enter "csrutil disable"
    • restart
    Note this disables a security feature new in Sierra. Hopefully this get's fixed and we can re-enable the security feature.
     
  15. HadiK macrumors newbie

    Joined:
    Oct 3, 2016
    #15
    I had the same issue after upgrading to Sierra on my mbp 2014 with genuine apple thunderbolt to ethernet adaptor. This fix does not work.
    Looking forward for a workable fix.
    tnx.
     
  16. turingalad macrumors newbie

    Joined:
    Nov 7, 2016
    Location:
    Post Falls, ID
    #16
    I also can't share internet via ethernet from my mac (mac mini late 2012, acOS Sierra v 10.12.1 ). This is what I get with that cmd...

    p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 11.0px Menlo; color: #000000; background-color: #ffffff} span.s1 {font-variant-ligatures: no-common-ligatures}

    Index Refs Address Size Wired Name (Version) UUID <Linked Against>

    122 0 0xffffff7f81135000 0x5000 0x5000 com.logmein.driver.LogMeInSoundDriver (4.1.48f99) 90DA5B4B-6D72-3F68-8D8E-8C4FE2044ACC <116 5 4 3>
     
  17. Shreya macrumors newbie

    Shreya

    Joined:
    Jul 20, 2017
    #17
    --- Post Merged, Jul 20, 2017 ---

    Were you able to resolve this?
     
  18. rickogorman macrumors newbie

    Joined:
    Aug 18, 2008
    #18
    This solved my problem. I had 'USB ethernet' in Network on a Late 2013 MBP retina, couldn't get ethernet to work via thunderbolt port, had router/internet access via wifi. Deleted the USB ethernet, rebooted, added 'thunderbolt ethernet' (USB ethernet wasn't an option) and viola, ethernet router access. Maybe I didn't even need to reboot, given the different config that was required.
     

Share This Page