lost everything in macJournal

Discussion in 'Mac Apps and Mac App Store' started by jeyf, Sep 29, 2017.

  1. jeyf macrumors 65816

    Joined:
    Jan 20, 2009
    #1
    guess this may have been posted before but worth another notice

    I have revision 6 of macJournal. About 50meg of daily stuff.
    the other day, all brand new, macJournal put up an err prompt; "object has no content". All the entries dispolayed zero length. Seems log in, password and un-encryption all worked. Seemed the entries were there only unable to display. Looks like the error crept in the other afternoon and was synced into every computer i have.

    this has a good ending
    i found a pre error backup on one of my virtual macs and was able to restore everything.

    If its important because you have been keeping years of a running daily journal than remember to keep several backups in the rotation. Like 15 backups so there is a recent pre error copy to fall back on.

    rude awakening; macJournal company peeps will post below but just the way it is...
     
  2. jeyf thread starter macrumors 65816

    Joined:
    Jan 20, 2009
    #2
    never got a reply from macJournal
    after i re did the journal form a backup it failed again
     
  3. ignatius345 macrumors 68020

    Joined:
    Aug 20, 2015
    #3
    I'd be very very hesitant to put all my stuff into one app with (what I assume is) a proprietary database like that. I'm using Ulysses (pre-subscription version) and even though its files are all save in markdown format and are somewhere in my iCloud file system, I still get a little skeeved out by having it all in one place. In fact, reading this makes me think I should peel off a backup copy of everything right now.
     
  4. jeyf thread starter macrumors 65816

    Joined:
    Jan 20, 2009
    #4
    makes you wonder if the next macjournal revision will ever be or if it will be subscription
     

Share This Page

3 September 29, 2017