Lost Mobile Data Connection on IP4

stohr

macrumors member
Original poster
Dec 23, 2009
75
0
Northern NJ
After jailbreaking, among loosing FaceTime and MMS, I now notice that I lost my AT&T Cellular Data. I tried restarting and resetting my network settings. I can't restore because I am not home and I do not use my MacBook for backups/syncing my iPhone. Anyone else have this issue?
 

bushido

Suspended
Mar 26, 2008
8,070
2,754
Germany
i just noticed it too ... i turned my wifi off and was like omg its no longer loading ... ive tried to restore my network settings as well and itunes told me a network update is available but its not helping :(
 

xxBURT0Nxx

macrumors 68020
Jul 9, 2009
2,189
2
Same issue here. I had the connection for a while after the jb but then it just stopped working. Hopefully a fix is found soon!
 

xxBURT0Nxx

macrumors 68020
Jul 9, 2009
2,189
2
Well I just added the source to Cydia from the jb your iPhone without losing FaceTime or mms thread and after a reboot sbsettings is now showing a data ip address. I would suggest trying it!
 

bushido

Suspended
Mar 26, 2008
8,070
2,754
Germany
damn just found it on the thread after i restored -.- now i have to put all my crap back on the iPhone and hope this actually fix my mobile data issue ... its not like its 4 am or anything sigh
 

WilliamG

macrumors G3
Mar 29, 2008
9,086
2,546
Seattle
Well I just added the source to Cydia from the jb your iPhone without losing FaceTime or mms thread and after a reboot sbsettings is now showing a data ip address. I would suggest trying it!
I have no data connection now either. I have 3G showing up with AT&T, but no web pages load anymore. Was working earlier this afternoon, but nothing now...
 

SS109

macrumors member
Sep 20, 2009
53
0
Same here. I have full bars + 3G but can't connect to anything. Voice still works, though. Tried restarting, removing/reinserting SIM and resetting Network Settings. Ended up restoring it. I'll wait until I hear that there is a fix or that the MMS/FT fix fixes this.
 

bella92108

macrumors 68000
Mar 1, 2006
1,610
0
Same issue here on a factory unlocked iPhone 4... had to re-key the APN settings but then everything was fine.
 

xxBURT0Nxx

macrumors 68020
Jul 9, 2009
2,189
2
I was having the same problems with full 3G bars showing and calls coming in but no Internet/data connection. If you go into cydia>manage>sources>edit>add and type in http://iphonedelivery.advinux.fr/cydia then click add. Wait for cydia to load the source then click done then click on the source and install the package and your problems should be fixed. This worked for me after I tried resetting network settings, restarts, resprings, removing sim, etc and had no luck with any of them
 

SS109

macrumors member
Sep 20, 2009
53
0
I jailbroke my phone again and narrowed down the problem to Mobile Substrate. Everytime I install it I lose data, MMS and FT. I uninstall it and everything goes back to normal. Weird.
 

Similar threads

Replies
0
Views
277
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.