lost mouse control

Discussion in 'Community Discussion' started by tomaquar, Apr 29, 2012.

  1. tomaquar macrumors newbie

    Joined:
    Aug 15, 2010
    #1
    My mouse is periodically responding erratically. It doesnt follow my finger and when I remove my finger the cursor drifts on its own. The screen also resizes its self when Im only using one finger.

    Has anyone else experienced this? Should I reinstall the OS ?

    Any input would be appreciated
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    What exact Mac with what exact Mac OS X version do you use?
    With "mouse", do you mean an actual computer mouse (if so, which exact one) or the built in trackpad of a MacBook Pro, MacBook or MacBook Air or an external trackpad like the Magic Trackpad?
    Does it also happen in another, even temporarily created, user account?
     
  3. tomaquar thread starter macrumors newbie

    Joined:
    Aug 15, 2010
    #3
    mouse

    OS 10.6.8

    Im using the track pad

    ----------

    macbook pro

    yes it happens on the "guest" account
     
  4. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #4
    And what exact MacBook Pro, I guess (though I don't know), it is a 2010 Unibody MacBook Pro?
    Have you installed anything trackpad related lately or changed something? Is the trackpad surface wet?
     
  5. tomaquar thread starter macrumors newbie

    Joined:
    Aug 15, 2010
    #5
    I bought it in 2010 and its has an aluminum body.

    I noticed it the first time after I cleaned it with an alcohol pad but it was only a small amount of alcohol. I though it might be because of it so I left it alone for an hour and it worked well. Now its started again 12 hours later but stops if I do a manual shutdown.

    Could a damp alcohol pad affect it 12 hours later ?
     
  6. bambp macrumors newbie

    Joined:
    Aug 18, 2012
    #6
    Just FYI -- I had the exact same problem. My MBP (2011 13'' i5) cursor would become erratic, right clicking, flicking between screens, and was often unresponsive to my actual input. It generally seemed that the trackpad was signaling inputs that weren't there, because when I would touch the trackpad with one finger it would respond as if I were using two, three or four.

    I tried everything. I cleaned the trackpad, even removed it to ensure it wasn't sticking, all to no avail.

    The only solution I found was to replace the trackpad. It's a super easy procedure and it's pretty cheap. I spent $40 (w/ shipping) for a trackpad and $2 for a tri-wing screwdriver.

    So far, no erratic behavior. I think this is a problem with the MBP trackpads, since so many people have the same issue. Hopefully Apple recognizes the issue soon.
     

Share This Page