Lost my confidence in Time Machine

Discussion in 'macOS Sierra (10.12)' started by lexvo, Nov 24, 2016.

  1. lexvo macrumors 65816

    Joined:
    Nov 11, 2009
    Location:
    The Netherlands
    #1
    My Time Machine backups are stalling (I am backing up to an external HD over USB). I discovered this three days ago. Since then I tried numerous things to get it working again, like:
    • resetting PRAM and NVRAM 
    • Boot in Safe mode 
    • Try a different external drive 
    • Removing the inProgress file on my external HD 
    • Removing the Time Machine plist file 
    • Let Spotlight reindex

    There seems to be a connection between Spotlight and Time Machine. After I did a reindex, the amount of data Time Machine was going to backup increased from 2 GB to 64GB, probably due to a lot of photos I copied from a SD card two weeks ago. 

    But this also means that my Time Machine backup hasn't been complete for two weeks. And I didn't notice it neither was there a warning (well maybe deep in the system logs but I'm not checking these on a regular basis). 

    Not having a complete backup and me not knowing it makes I lost faith in Time Machine. If I'm overlooking something or if someone has some advice I'd like to hear it. 
     
  2. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    Have you tried to manually "verify" the backup?
     
  3. Ebenezum macrumors 6502a

    Joined:
    Mar 31, 2015
    #3
    If haven't already I would take a look at the Pondini Time Machine site: http://pondini.org/TM/Troubleshooting.html

    It hasn't been updated for a few years but most of the information should be helpful.

    I agree with BrianBaughn, checking the backup with Disk utility is a good first step.

    Previously Time Machine logs could be found with Console but Apple "improved" it in Sierra and good luck trying to find older logs with it. You could alternatively try LogLogger. Logs may shed light to what causes the problem.

    It might be a good idea to start using some other backup software in addition to Time Machine, doing so will minimise the changes that possible bug in Time Machine would ruin all your backups... (For the record in my experience Time Machine isn't the most reliable backup software I have used).
     
  4. lexvo, Nov 25, 2016
    Last edited: Nov 25, 2016

    lexvo thread starter macrumors 65816

    Joined:
    Nov 11, 2009
    Location:
    The Netherlands
    #4
    I checked the backup HD (and also my Mac HD) with Disk Utility twice and found no problems.
    --- Post Merged, Nov 25, 2016 ---
    Yes, I found Pondini's site (great site by the way) and tried a lot of the tips. Alas nothing helped.

    Today I downloaded Carbon Copy Cloner and at this moment I'm making a bootable copy of my whole Mac HD.
     
  5. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #5
    Have you checked whether the files have been backed up in Time Machine’s history for the last two weeks?

    It is generally not a bad idea to rely on two backup mechanisms.
     
  6. lexvo thread starter macrumors 65816

    Joined:
    Nov 11, 2009
    Location:
    The Netherlands
    #6
    Well, the stalling started with a backup of 2GB. When I did some things mentioned above the backup size grew to 60GB. I don't have a lot changed normally, but I copied a lot of RAW photo files from a SD card to my iMac two weeks ago. Therefore I concluded that my time machine backup hasn't been working correctly for two weeks.

    And I'm making a clone of my iMac HD via Carbon Clone Copier now :)
     
  7. lexvo thread starter macrumors 65816

    Joined:
    Nov 11, 2009
    Location:
    The Netherlands
    #7
  8. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #8
    Time Machine got dodgy for me back at el Cap or Yosemite. It just started going corrupt after a few weeks or months. Couldn't access anything but latest docs. Still use it, as it usually does a nice hourly backup on docs I'm working on.
    I test it with a doc I use for that purpose by changing the doc every week or so, and checking whether I can restore to earlier versions.
    Essential to have an external drive, or Cloud, BU as well.
     
  9. lexvo thread starter macrumors 65816

    Joined:
    Nov 11, 2009
    Location:
    The Netherlands
    #9
    I agree! Before this happened to me I was always wondering why people were using apps as Carbon Copy Cloner, but now I understand :)
     
  10. lexvo thread starter macrumors 65816

    Joined:
    Nov 11, 2009
    Location:
    The Netherlands
    #10
    It looks like its a problem in Sierra. In the Apple discussions thread I mentioned above, some users report they have contact with Apple engineers who are investigating the problem. Some users report they solved the problem by downgrading to El Capitan. A clean install of Sierra does not help.

    I found the same in the following Dutch thread were one user reports frequent contact with Apple.
    https://genius.appletips.nl/discussion/3422/time-machine-backup-in-macos-sierra

    Hopefully Apple will solve this soon.

    In the meanwhile I have switched to Carbon Copy Cloner for my backups, as I can't get Time Machine to work correctly, despite following a lot of suggestions from other users.
    --- Post Merged, Nov 26, 2016 ---
    And some more links to webpages about Time Machine problems in Sierra:
    http://elcapitanslow.com/fix-time-machine-problems-mac-os-sierra/
    https://eclecticlight.co/2016/11/23/time-machine-problems-in-macos-sierra/
    http://blog.macsales.com/38608-common-problems-after-installing-macos-sierra-and-how-to-fix-them
     
  11. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
    #11
    Give CCC a try, and you'll never look back… ;)
     
  12. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #12
    I second the suggestion of CCC. I use it along with Time Machine. I always like to have a backup of the backup.
     
  13. lexvo thread starter macrumors 65816

    Joined:
    Nov 11, 2009
    Location:
    The Netherlands
    #13
    Yes, like I said I already started using CCC :)
    --- Post Merged, Nov 27, 2016 ---
    Agreed, I already started using CCC a few days ago. I think I will try Time Machine again after one or two releases of Sierra.
     

Share This Page