Lost my phone service! Accidental Unlcok!

Discussion in 'Jailbreaks and iOS Hacks' started by Dickeythepirate, Dec 10, 2009.

  1. Dickeythepirate macrumors newbie

    Joined:
    Dec 10, 2009
    #1
    I got my Iphone 3g 8gb about a year ago, Not long after I had it, I jailbroke it, things were working fine.

    Last night I decided that I wanted to upgrade(I had been stuck on the 2.2.1 firmware, So i downloaded Blackra1n.exe and used that but not before I loaded in the ipod2,1_3.1.2_7D11_restore.ips. It was late, and I unlocked the phone when I had no need to, and now I think I've gone and ruined my iphone!!

    I am currently stuck with the following:

    Prior to installing 3.1.2 I had 2.2.1 and modem Firmware of 02.28.00

    My modem firmware has not updated, but the phone version has, and I can do NOTHING to get service back to my phone, I talked to the tech support guy on the phone for 2 hours trouble shooting tonight. Wifi works, my apps work, its just the phone doesn't have the phone part to it any longer.


    My options are to try and vanilla the phone, to take cydia off of it, which I also have been unable to do, and once I do that I can take it to At&t and get a replacement for considering its still under warranty.

    ...however I would prefer just to get the damn thing working.
    1. The simcard switch did not work, my simcard WORKS in other iphones. Working iphones simcards DO not work in my phone.
    2. I put ultrasn0w on the phone at some point late last morning and unlocked it and it's been downhill since then considering I didn't need to do that
    3. Installed ih8sn0w iREB -v 3.1 for windows and used that a few times as well as resetting and reinstalling and rolling back to all the backups ive had.
    Please any help would be greatly appreciated.

    Thanks im drowning here.

    Dickey.
     
  2. 1ofthedavids macrumors regular

    Joined:
    Jun 8, 2009
    #2
    Did you seriously use an iPod firmware to update an iPhone? I don't even think that's possible... but honestly, I've never tried.

    Unless that's a typo, I think you pinpointed the problem right there. Get an iPhone firmware and use that. Also, have you tried using the official update methods (iTunes + official firmware) instead of using a bunch of third party programs to undo the jailbreak/unlock? I'd suggest going the official route, then once you get it back to a normal state, then jailbreak it.
     
  3. kAoTiX macrumors 6502

    kAoTiX

    Joined:
    Oct 14, 2008
    Location:
    Midlands, UK
    #3
    I did the same thing while jailbreaking on a mac using pwnage tool. Basically I said put on the 'hacktivate' option so you can then unlock and put in any sim card. Well that didnt work at all and I was left with no service of any kind but an otherwise fully functioning iPhone.

    Your best bet is to literally start over.
    Do you need to unlock or want to keep that option open?

    You can unlock on the latest baseband so there's really no need to keep it from being updated.
     
  4. pixelated macrumors 6502a

    pixelated

    Joined:
    Oct 21, 2008
    #4
    Im confused to why you don't just restore and JB again (obviously with the iphone firmware)
    I assume you accidentally installed Blacksn0w after you made it Ra1n? If thats caused the problems AND you dont need the unlock just don't install it next time.
     
  5. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #5
    Restoing a 3G to official Apple firmware is VERY simple. There is a sticky at the top of the thread list.
     
  6. Dickeythepirate thread starter macrumors newbie

    Joined:
    Dec 10, 2009
    #6
    Yes the Ipod hardware was a typo, i did use iphone firmware. The problem is that When I do reset my phone, I still have cydia installed and It never finds service.


    I've tried re-storing my iphone to its original state using the sticky on the top of the threads yet, it NEVER connects to at&t since I unlocked it....

    But even after I go into the phone settnigs and reset all files and then do a fresh recovery. Cydia is still installed, and i still have no phone service.


    I spent like 12 hours yesterday trying to troubleshot this, I think one of the problems is my modem Firmware of 02.28.00

    I am honestly willing to try or do anything to get this working.
     
  7. tctony macrumors 6502a

    tctony

    Joined:
    Jun 15, 2009
  8. Dickeythepirate thread starter macrumors newbie

    Joined:
    Dec 10, 2009
    #8
    Tried that... No luck.


    How should I go about updating my modem ware, and what should it be at? I really think thats causing major problems.
     
  9. Dickeythepirate thread starter macrumors newbie

    Joined:
    Dec 10, 2009
    #9
    so after doing a restore to oringal, i still have cydia and winter board installed, and i still cant get my phone service.


    Can any one please help me. How does one go about relocking a phone to use at&t?!

    Anytime i reboot or reload, or do anything, it restores the phone to the 3.1.2 state with cydia and no phone service. What am i doing wrong? Can any one please help...?
     
  10. fishnride macrumors newbie

    Joined:
    Jan 29, 2009
    Location:
    Lakeland, FL
  11. RandomKamikaze macrumors 6502a

    RandomKamikaze

    Joined:
    Jan 8, 2009
    Location:
    UK
    #11
    Can you take a screenshot please.

    Settings > General > About

    Make sure it shows the Version and Modem Firmware fields in the same screenshot
     
  12. Knowlege Bomb macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #12
    After you restore in iTunes are you selecting "Restore from Backup" or "Set up as new"?

    If you're restoring from backup that is your issue as that retains most (if not all) of your jailbreak data. I really don't think it's possible to restore and set up as new and still have traces of the jailbreak come through.
     
  13. Dickeythepirate thread starter macrumors newbie

    Joined:
    Dec 10, 2009
    #13
    I tried that with no luck, I go from having ---- as my signal to it saying NO SIGNAL

     

    Attached Files:

  14. enoC macrumors 6502

    enoC

    Joined:
    Jul 2, 2009
    Location:
    Denmark
    #14
    Start by deleting the ipsw from the iTunes Software folder. Then put the iPhone in DFU-Mode and restore it. And remember NOT to restore from backup, but set it up as a new iPhone.
    When this is done, jailbreak it with blackra1n and unlock it with blacksn0w from Cydia.
     
  15. Wicked1 macrumors 68040

    Wicked1

    Joined:
    Apr 13, 2009
    Location:
    New Jersey
    #15
    One of the reasons I used Pwnagetool, then used Cydia and Icy, but after having some wierd issues, I reset the phone to factory default.

    I know the hacks are good but eventually Apple will catch up and there will be no Jailbreaking later on, they will prevent it, just not sure when.

    Dude good luck, but have you tried to Restore the phone using a clean computer with iTunes, I figure there might be some issues with iTunes on your current computer, so I would try another computer with a clean version of iTunes.
     
  16. Dickeythepirate thread starter macrumors newbie

    Joined:
    Dec 10, 2009
    #16
    That explains my results of fiddling for the last bit.

    Ill try this as soon as I find the itunes software folder...

    But I have done both, restored from back up and made a new phone. However it always stays jailbroken. Will deleting the software folder and DFU-mode restorying it fix that? And do I need to unlock it with blacksn0w? I have at&T?
     
  17. kinyo macrumors newbie

    Joined:
    Dec 6, 2009
    #17
    use DFU to downgrade back to 2.2.1 or 2.2 if u r getting 16xx error then try again.until it succeed. ofcuz use iphone 3g fw,for downgrade to 2.2.1 ,actually i didnt success downgrade back to 2.2.1 i was failed about 10 times and no luck always get 16xx error,then i tried 2.2 about 2 times then i succeed downgrade back to 2.2, i used itunes 9.0 for the downgrade, sorry for my bad english, hope this can able to help with ur situation.
     
  18. RandomKamikaze macrumors 6502a

    RandomKamikaze

    Joined:
    Jan 8, 2009
    Location:
    UK
    #18
    No you don't need to unlock if you are on AT&T.

    Please post back when you have deleted the IPSW file and re-downloaded.

    Also, with the backups, although it will carry over some jailbroken data, it won't include apps such as Cydia.

    A lot of people are mentioning Pwangetool, did you use this to make the IPSW file you restored on to your phone?

    Have you just pushed the restore button in iTunes?

    Also, please advise on the outcome of a DFU restore
     
  19. Dickeythepirate thread starter macrumors newbie

    Joined:
    Dec 10, 2009
    #19
    I deleted the old IPSW file and everything is working fine. Thanks every one for your help.
     

Share This Page