Lost network connection after computer sleep

Discussion in 'OS X Mavericks (10.9)' started by infantrytrophy, Oct 27, 2013.

  1. infantrytrophy macrumors regular

    Joined:
    Oct 27, 2013
    #1
    After installing OSX Mavericks I have noticed that my internet connection is lost after the computer "wakes up" from sleep mode. Re-booting restores the connection.

    My iMac is connected by ethernet cable to a DLink DIR655 "N" router (gigabit ethernet). I never had this problem before installing OSX Mavericks. There is also a DLink gigabit switch between the computer and router.

    Is this a bug in Mavericks? Or is there some setting that I need to adjust?
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Try going to the Network pane in System Preferences and click the gear at the lower left then select set service order. Now drag ethernet to the top of the list then save your way out of there.
     
  3. infantrytrophy thread starter macrumors regular

    Joined:
    Oct 27, 2013
    #3
    OK, tried that, and the internet connection survives one (and only one) sleep cycle. After the second sleep/wake-up cycle, the internet connection is lost until a re-boot is done. I also tried "Renew DHCP Lease" in the advanced section of the Network Pane, but there is still no access to the internet.

    The local network connection seems to be OK. In the Network pane of System Preferences, the network indicates "connected". Web site pages will not load in Safari, however, and the Mail application will not connect to the ISP's mail server.

    Any other ideas?
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    Just for grins... can you try disconnecting the ethernet cable and connect over wifi to see if the issue persists. That would point to the switch and cables as issues perhaps.

    Another idea... in the Network pane try removing the ethernet entry altogether then add it back and set it up again.
     
  5. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #5

    Look at the IP listed when this happens. It sounds like possibly the system is not connecting to the network DHCP server and self assigning an IP address, so it is not "truly" connected to the network, but in reality creating its own local network.
     
  6. sim667 macrumors 65816

    Joined:
    Dec 7, 2010
    #6
    Could you put in a dhcp reservation for the hardware address of your ethernet port?

    I've had to do this to try and resolve my wake on ethernet issues.
     
  7. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #7
    I second this as I always use statics defined on my server, just makes it easier for me to get to whatever machine I need to access/ repair/ update and I have never had waking issues.
     
  8. infantrytrophy thread starter macrumors regular

    Joined:
    Oct 27, 2013
    #8
    OK - disconnecting, then reconnecting the ethernet cable WORKS!

    I'm not sure whether or not that points to a cabling or switch issue, since the same cabling and switch worked fine before installing OSX Mavericks. Regardless, I'll try bypassing the gigabit switch and plug in a direct cable to the router, just to see if that works.

    It seems to me that something changed with OSX Mavericks. There is a new "issue" with "waking up" from the sleep mode.

    I'll try removing/re-installing the ethernet entry also. Since I have a have a work-around now (although clumsy), I don't want to mess things up more than they are. :)

    "The enemy of good enough is better ... "

    ----------

    I looked at the IP address before the computer goes into sleep mode, then after waking up, then after disconnecting and re-connecting the ethernet cable. Result: the computer has the same IP address (in the local network). If I understand this correctly, the same local IP address is re-assigned even after re-connecting via ethernet. This must be the next free address in the available list of local IP addresses that the router's DHCP feature uses.
     
  9. infantrytrophy thread starter macrumors regular

    Joined:
    Oct 27, 2013
    #9
    also tried resetting the SMC - no dice

    I also tried resetting the SMC (System Master Controller) as instructed here:
    http://macs.about.com/od/usingyourmac/qt/Resetting-The-Smc-System-Management-Controller-On-Your-Mac.htm

    This did not resolve the problem. After the 2nd time the computer goes into sleep mode, the internet connection is lost.

    Clarification to above comment on ethernet cable: disconnecting/reconnecting the ethernet cable sometimes corrects the problem; other times not.

    Re-setting the service order, or "toggling" (clicking "apply") the service order in the network pane of system preferences resolves the problem.

    Any other thoughts?
     
  10. ms1 macrumors newbie

    Joined:
    Oct 30, 2013
    #10
    Hi,

    I have an MB Air with a 27'' display and I have the same problem since I updated to 10.9 but I have a static IP and no DHCP. Also nothing changed on my network (lan, switch, router, ...).After sleep mode network status is green but I have no connection (no mail, no safari connection, ...)
    My workaround is to change the ip address to 192.168.1.32 and then back to .31.
    This will restart the network service (or however this is called in OSX) and then it works.


     
  11. kungfupanda macrumors newbie

    Joined:
    May 27, 2008
    #11
    Seems like this is a common problem.....

    and it's surprising that people with static IP addresses are worst hit.....

    https://discussions.apple.com/message/23650384?ac_cid=tw123456#23650384

    Any tips or suggestions would be most welcome. I had a perfectly fine MacBook Air before the upgrade to Mavericks, and now it won't bring the network up after waking from sleep. Nothing has changed about the hardware.

    Things I have tried - resetting the SMC, resetting the NVRAM, adding a new network location, reordering the network service etc etc. Nothing has worked.

    Cheers, Jon
     
  12. TheBacklash macrumors regular

    TheBacklash

    Joined:
    Oct 23, 2013
    #12
    Great..
    This is one of the bugs in Lion that took Apple forever to get fixed.

    Had to turn WiFi off/on every time.
    *Crosses fingers it's not back*
     
  13. squeakr, Nov 3, 2013
    Last edited: Nov 3, 2013

    squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #13
    It seems that the way that people are assigning their static may be the issue. As it looks like most are defining their static on the computer itself instead of defining it within the routing table specifically for the computer. Without the router/ routing device having the static routing assigned/ defined, the static addressing is just not relying on the assignment route for its addressing and instead hoping that their assigned address doesn't step on another already assigned on the system or cause collisions. The best way is to assign the statics on the router so they get built within the routing table and not just arbitrarily assigning an address within the range on their computer which can and may cause all sorts of issues.

    This could be one of the main issues as the hardware is now responding to different code sets to save power and is thus releasing the connections and not renewing with the router. Having a static can help if the route path recognizes and sets the routing up beforehand. Just assigning a static within the network settings doesn't insure that this address is available when connecting to the network, which defining in the routing tables does insure.
     
  14. jnojr macrumors newbie

    Joined:
    Nov 5, 2013
    #14
    In Terminal, try:

    sudo en0 down && sudo en0 up

    It does take several seconds for the interface to come back. I've noticed that I get my IPv6 SLAAC address very quickly, then my DHCP6 address, and my DHCP-assigned IPv4 address last.

    Assuming that works, you could run a script in the background that pings the gateway every few seconds, and if it doesn't get a response, drop and bring up the network interface.
     
  15. Guy1717 macrumors newbie

    Joined:
    May 26, 2011
    Location:
    Belgium
    #15
    I bought two weeks ago a Macbook pro retina 13inch with Mavericks preinstalled. I have wifi connection with DLINK DIR-655.
    Wifi connection drops several times a day and after sleep and then wake up it will sometimes not connect at all, i have to turn off wifi and then turn it back on again.

    My Ipad 4 and Ipod touch5 have no issues like that. Also my soon to be ex Windows 7 laptop had never problems with wifi on tat DLINK wifi. I have that DLINK DIR655 for about two years and never had problems exept now with the MBpro.

    I can't find a solution on the net and I hope Apple will come with an update soon. I called Apple support here in Belgium but they don't know what the problem is.

    Guy
     
  16. kungfupanda macrumors newbie

    Joined:
    May 27, 2008
    #16
    Respectfully...this is nonsense. Identical hardware both in home and office settings (where you can't specify MAC addr -> fixed IP address, because you're not the sys admin guy or gal) is showing this fault after mavericks upgrade. I know for certain that I have no IP conflicts before or after upgrade, and yet here we are. Basically Apple took a fork of Lion (pre the fix for this problem) as its code base for Maver$h1ts and is now playing catch up. This doesn't say a lot for Apple's QA, testing programme.

    Cheers,

    Jon
     
  17. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #17
    If not the it guy how do you know there are no conflicts? My explanation is no more nonsense than yours. Do you know that the same hardware is being used in the office and home, unless you are speaking of the only the hardware in the computer?

    How do you know that is where the code came from as well. Just as you are calling nonsense, so am I as your claims are making a stretch.
     
  18. tofagerl macrumors 6502a

    tofagerl

    Joined:
    May 16, 2006
    #18
    No need to point fingers guys, trying to fix the problem is better than not trying to fix the problem.

    I think this is something that Apple needs to patch. I have the same problem with a week old MBPr 13", and nothing solves it, including making a network location, deleting all networking preferences, or the infamous "service order".
     
  19. kungfupanda macrumors newbie

    Joined:
    May 27, 2008
    #19
    Sorry baad day yesterday!

    I guess it's just more likely that since a lot of people are having this problem then it's probably an OS problem rather than some config problem that's been discovered.

    Cheers
    Jon
     
  20. TopKatz macrumors newbie

    Joined:
    Nov 12, 2010
    #20
    I have this problem with a wired connection with DHCP. The only fix that works is a restart. It is not after every sleep, and it is not all the time. Some times its immediate, and some times it takes a minute. My apple TV can cause the issue also (so wake on network activity).
     
  21. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #21
    One possible scary fix that is really easy has been floating around the Net.

    In 10.9 open System Preferences->Network tab and from their turn off your wireless. Then while still in the same Network pane click in the left hand column - sign and then in the right hand pane click 'Apply'. Wait a minute. Then go back in the System Preferences->Network pane and click the + sign to re-add your Wi-FI and rejoin you wireless network. Don't forget after this to click the 'Apply' button to save all your work.

    Good Luck.
     
  22. Fireblade69 macrumors newbie

    Joined:
    Jun 22, 2014
    #22
    Mac won't connect to internet after returning from sleep

    This is happening to my mac also and I cannot find any faults.

    I have a static IP address - has anyone found a fix please.

    Many thanks



    Shaun
     
  23. valiot macrumors newbie

    Joined:
    Jan 19, 2008
    #23
    I'm having the same problem with osx 10.9.4 using a thunderbolt to ethernet adaptor. Network is lost after wakeup from sleep. The only option is to unplug the thunderbolt adaptor and plug it in again. I've setup a static IP address at the router (airport extreme).
     

Share This Page