lost original admin password

Discussion in 'Mac Basics and Help' started by ihatethispart, Jun 29, 2014.

  1. ihatethispart macrumors newbie

    Joined:
    Jun 29, 2014
    #1
    so i'm pretty new to OSX and a macbook was given to me. unfortunately while i can login into 2 of the user accounts, the administrator password was not given to me.

    i tried resetting it by going into the terminal and entering "sudo passwd root" and following the prompts.

    but when I tried to install mavericks and it prompted me for the administrator password, the new password didn't work. I'm familiar with linux systems. is root not the same thing as administrator in osx? this is really annoying I just want to reformat the macbook and there's no apple store nearby.

    edit: and i need the "original" administrator password. at this point I have access to all user accounts (all 3 are administrator), but I don't have the original administrator password
     
  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    You don't need the "original admin password" if all 3 accounts are admin.
    Just log out, then log back in to one of the other accounts, then change the password for the (main) account from the Accounts pref pane. If you have 10.7 or newer, then the Accounts pref pane will be User & Groups - same thing.
    You have to unlock that Accounts pane by clicking on the padlock in the lower left corner, and entering the admin password for the user that you are logged in to. Choose the other account that you need to change, and then click "Reset Password…"
    And, there you go.
    You can log out then, and log back in to the account that you just changed, using that new password :D

    To answer your question about root and admin: The root user is a step higher in the system, compared to the admin user, and the Admin user level is a step above a standard user, if you have one.
    Here's an example for you to think about:
    If you log in as a standard user, you can't use a sudo command in the terminal. It's not allowed at that standard user level.
    The admin user has full use of the sudo command, which requires the admin password to use.
    The Root user, doesn't need to use the sudo command at all, because the root level already has authority to do anything without using a password - including dangerous stuff like deleting system files while the system is running. You should not enable the root user, unless really necessary, (and you know exactly what you are doing), and then disable the root user when you don't specifically need it. Reason is the security level for the root user leaves the system almost completely open from the outside.
     

Share This Page