Lost permissions of own Home folder

Discussion in 'OS X Mavericks (10.9)' started by hyperipod, Oct 25, 2013.

  1. hyperipod macrumors member

    Joined:
    Jun 27, 2010
    #1
    I downloaded OS X server (for Xcode) and then experimented with the file sharing options and activated the sharing of my Home folder (/Users/Felix/, in my case) and then changed the permissions (in the Server app) so that not everyone could access my shared Home folder but it appears that it changed the permissions of my Folder!

    So now I have an unusable computer...

    I tried going in single-user mode and the steps here: http://reviews.cnet.com/8301-13727_7-20013630-263.html

    But step 1 gave me an error "Could not clear ACL, blablabla, Read-Only File-System"

    So I tried to change the -N argument to -E, as proposed but it just seemed like the command got stuck (pressing CTRL+T said the command was "waiting") though I waited 45 minutes and still no change...

    So I cancelled it and tried the following steps and finally tried to reboot only to find out Mavericks just won't boot! (Apple logo and spinning thing forever (with high CPU usage))

    I then tried going in recovery (where I repaired my disk permissions and my disk) to reinstall Mavericks but I get an error when trying to install (I don't remember what the error was though but I don't think it's really important since the real issue is with my home folder)

    Anybody know what I could do? My last Time Machine backup dates from 20 days ago (I know, I know)

    Thank you
     
  2. D A macrumors regular

    Joined:
    Nov 21, 2008
    #2
    You have access to the Terminal in recovery mode, so you could try to run the commands there if you haven't already. I'd also try with setting permissions on your folder with chmod to 777 (give everyone read-write-execute rights) if the other commands don't work.
     
  3. hyperipod, Oct 25, 2013
    Last edited: Oct 25, 2013

    hyperipod thread starter macrumors member

    Joined:
    Jun 27, 2010
    #3
    Thanks for the reply,

    I just tried running chmod -R 777 /Users/Felix

    And I got thousands of messages (for every file) "Unable to change file mode on /Users/Felix/*******: Read-only file system"

    At this point I'm ready to set up a new user. I just want my data back...

    EDIT: I tried it in single-user mode! I'll try it in recovery mode to see if it changes anything.

    EDIT2: Seems to be running fine so far! :D
     
  4. hyperipod thread starter macrumors member

    Joined:
    Jun 27, 2010
    #4
    I've been able to chmod 777 my whole home folder but now my system still won't boot... (Apple logo and spinning thing, forever)

    I'll try reinstalling Mavericks.
     
  5. D A macrumors regular

    Joined:
    Nov 21, 2008
    #5
    I just remembered that I recently had an issue with the computer not booting (stuck on the same screen as you) properly after working with some kexts.

    Turns out one of the kexts in /System/Library/Extensions didn't have the right permissions/ownership. Once setting the permissions and ownership to match the rest of the kexts the system booted up without any problems.


    So I'd check to see if any LaunchAgents, LaunchDeamons or Kexts have different permissions to those around them. Simply reinstalling Mavericks may not get rid of any offending kexts or plists.
     
  6. hyperipod thread starter macrumors member

    Joined:
    Jun 27, 2010
    #6
    Haha, well I already reinstalled Mavericks so it's too late :p

    But the thing is... even after running chmod -r 777 /Users/Felix (and I tried doing it again once in my session (I can boot now and I can even login)) I still don't have the permissions to see what's in my Home folder...

    Any idea what I can do? :s
    I think I've tried everything now...

    (When I use sudo I can see inside the folder...)
     
  7. parkds macrumors regular

    Joined:
    Jan 23, 2003
    #7
    I had the same issue, locked out of almost all of my home folders. Nothing was working to fix the permissions and when the OS stopped recognizing my password I ultimately decided I had to do a clean install. Unfortunately when my home folders got locked it borked my TimeMachine back up. Transferred as many of the locked folders to another drive as I could and wiped the drive and then copied back my data and restored my apps.
     
  8. D A macrumors regular

    Joined:
    Nov 21, 2008
    #8
    I'd try to retake ownership of the files/folders (using chmod -r) to see if that helps.
     

Share This Page