Lost rights to external drive

cupik

macrumors newbie
Original poster
May 27, 2014
10
0
SOLVED


Hello,
I have quite puzzling issue with my external drives.
I have macbook pro from 2010 with Mavericks and old macbook from 2006 with osx server 10.6.8
I tried to share all folders between both (via get info window)
when i choose to do so, I also used apply to enclosed items option.
That took a while, and after that I experienced severe problems on both computers and external drives.
My rights got totally messy.
I had to reinstall mavericks on the newer laptop, and on the server laptop I can only get to the single user or verbose mode. On the old macbook with osx 10.6.8 i can't get to GUI at all.
I Also lost rights to my external drives. All rights are set to custom mode and I cant change it.

I simply reinstalled mavericks on the newer laptop, but cant access external drives. There is a pop up message about insufficient rights when i try to open it.
Is there any way to access those drives and change the rights so that I can actually use them?
Is the any way I can access GUI on the old macbook?

in single user mode i type ls and i can see all folders and files, just cant access gui.

Any idea how i can fix it?
 
Last edited:

Weaselboy

Moderator
Staff member
Jan 23, 2005
30,433
10,234
California
I simply reinstalled mavericks on the newer laptop, but cant access external drives. There is a pop up message about insufficient rights when i try to open it.

Is there any way to access those drives and change the rights so that I can actually use them?
See my post #6 in this thread. Delete the file /var/db/volinfo.database and it will reset all your externals to the default ignore ownership setting.

On the old machine, I think you will need to reinstall the OS to get that straightened out. Don't erase the disk, just reinstall over top of the existing install.
 

cupik

macrumors newbie
Original poster
May 27, 2014
10
0
See my post #6 in this thread. Delete the file /var/db/volinfo.database and it will reset all your externals to the default ignore ownership setting.

On the old machine, I think you will need to reinstall the OS to get that straightened out. Don't erase the disk, just reinstall over top of the existing install.
Hello,
I have tried to delete this file but i don't have rights to do that.
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
30,433
10,234
California
Hello,
I have tried to delete this file but i don't have rights to do that.
Did you run this command from my post #6 in the other thread I linked? The sudo command will give you the elevated privileges you need to do this. You will be asked for your password.

Code:
sudo rm /var/db/volinfo.database
 

cupik

macrumors newbie
Original poster
May 27, 2014
10
0
Did you run this command from my post #6 in the other thread I linked? The sudo command will give you the elevated privileges you need to do this. You will be asked for your password.

Code:
sudo rm /var/db/volinfo.database
Hello,
Yes, I tried that, also logged in as root and deleted the file. rebooted, still can't access external rive
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
30,433
10,234
California
Hello,
Yes, I tried that, also logged in as root and deleted the file. rebooted, still can't access external rive
I'm confused. You said you were not able to run the command I gave you, but this second post sounds like you were able to and it did not have the desired effect. Can you clarify exactly what you did and the result.
 

cupik

macrumors newbie
Original poster
May 27, 2014
10
0
I'm confused. You said you were not able to run the command I gave you, but this second post sounds like you were able to and it did not have the desired effect. Can you clarify exactly what you did and the result.
i did the command in the terminal, but that didn't help.
then i removed manually the file as root. after that the file is modified in a way that there is 0 at the end of the truing responsible for hard drive, but can't change to 0 in the external drive string.
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
30,433
10,234
California
i did the command in the terminal, but that didn't help.
then i removed manually the file as root. after that the file is modified in a way that there is 0 at the end of the truing responsible for hard drive, but can't change to 0 in the external drive string.
Unplug all external drive then run the command to delete the file. A new, blank version of the file will automatically be created. Now plug in an external and its rights will default to ignore ownership being check marked. You don't need to edit the file itself.
 

cupik

macrumors newbie
Original poster
May 27, 2014
10
0
Unplug all external drive then run the command to delete the file. A new, blank version of the file will automatically be created. Now plug in an external and its rights will default to ignore ownership being check marked. You don't need to edit the file itself.

i did as you said, and the outcome in terminal is:

sudo: /var/db/sudo writable by non-owner (040777), should be mode 0700
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
30,433
10,234
California
i did as you said, and the outcome in terminal is:

sudo: /var/db/sudo writable by non-owner (040777), should be mode 0700
Just to be clear... you need to run that command I gave you on the newer Macbook running Mavericks, not against the external drive. Copy and paste the command from my forum post into Terminal while booted to Mavericks on the Macbook and it should work.
 

cupik

macrumors newbie
Original poster
May 27, 2014
10
0
Just to be clear... you need to run that command I gave you on the newer Macbook running Mavericks, not against the external drive. Copy and paste the command from my forum post into Terminal while booted to Mavericks on the Macbook and it should work.
Hello
Yes, I run it on the newer macbook, but my problem is with external hard drive, i can't access it. i managed to fix newer macbook with system reinstallation. the problem is with the external drive. i can't access IT
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
30,433
10,234
California
Hello
Yes, I run it on the newer macbook, but my problem is with external hard drive, i can't access it. i managed to fix newer macbook with system reinstallation. the problem is with the external drive. i can't access IT
I understand, and running that command should reset the externals all to ignore ownership being cheek marked, which should allow you to get beyond any permissions errors. Perhaps you have something else going on here.
 

cupik

macrumors newbie
Original poster
May 27, 2014
10
0
I understand, and running that command should reset the externals all to ignore ownership being cheek marked, which should allow you to get beyond any permissions errors. Perhaps you have something else going on here.
Well, let's add few details.
Originally I was trying to share everything with everything.
In other words, I wanted to make the whole mac book hard drive and external hard rives as shared folders. I tried to do the same on the olde server macbook. after that process, when I wanted to make the whole hard drive and external hard drives as shared folders I got into problems.
I tried your command several times, I deleted the file several times and rebooted.
I still can access the external drive. I have 500GB and nearly 1Tb on the other one of personal photos, movies and films.
Any idea how to access it? Whenever I try to change the rights on the external drive (it is set as custom now) I can't do it. It automatically returns to custom setting.
 

Weaselboy

Moderator
Staff member
Jan 23, 2005
30,433
10,234
California
Well, let's add few details.
Originally I was trying to share everything with everything.
In other words, I wanted to make the whole mac book hard drive and external hard rives as shared folders. I tried to do the same on the olde server macbook. after that process, when I wanted to make the whole hard drive and external hard drives as shared folders I got into problems.
I tried your command several times, I deleted the file several times and rebooted.
I still can access the external drive. I have 500GB and nearly 1Tb on the other one of personal photos, movies and films.
Any idea how to access it? Whenever I try to change the rights on the external drive (it is set as custom now) I can't do it. It automatically returns to custom setting.
With ignore ownership check marked, it does not matter what the folder permissions are as that overrides all those settings. If you select the external in Finder then do a command-i to get info is the ignore ownership box checked? That is what you want.

Go into the Sharing pref pane and make sure you have all that sharing turned off.

 

cupik

macrumors newbie
Original poster
May 27, 2014
10
0
With ignore ownership check marked, it does not matter what the folder permissions are as that overrides all those settings. If you select the external in Finder then do a command-i to get info is the ignore ownership box checked? That is what you want.

Go into the Sharing pref pane and make sure you have all that sharing turned off.

Image

I have done that in the first place, and still can't access it.
Permissionas are set to custom.
ignore ownership box doesn't help, still can't open it.
 
Last edited:

Weaselboy

Moderator
Staff member
Jan 23, 2005
30,433
10,234
California
I have done that in the first place, and still can't access it.
Permissionas are set to custom.
ignore ownership box doesn't help, still can't open it.
I'm out of ideas. Sounds like maybe all that sharing business you had setup may have messed things up. :confused:
 

cupik

macrumors newbie
Original poster
May 27, 2014
10
0
I'm out of ideas. Sounds like maybe all that sharing business you had setup may have messed things up. :confused:

For those with similar problems.

I have found a solution
In terminal, when the drive in question is connected, just type:

sudo chflags -R nouchg /Volumes/{G,R}*
sudo find !$ -type d -exec chmod a+x {} \;
Of course add proper volume name in place.
 
Last edited:

Weaselboy

Moderator
Staff member
Jan 23, 2005
30,433
10,234
California
For those with similar problems.

I have found a solution
In terminal, when the drive in question is connected, just type:

sudo chflags -R nouchg /Volumes/{G,R}*
sudo find !$ -type d -exec chmod a+x {} \;
Of course add proper volume name in place.
Glad you got it sorted out. Those commands are over my little pinhead. :D
 

tomatoking0815

macrumors newbie
Oct 10, 2015
1
0
For those with similar problems.

I have found a solution
In terminal, when the drive in question is connected, just type:

sudo chflags -R nouchg /Volumes/{G,R}*
sudo find !$ -type d -exec chmod a+x {} \;
Of course add proper volume name in place.
Thank you cupik! You are invincible!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.