Lost wireless scanner; wireless printer still there

Discussion in 'MacBook Air' started by gowild2000, Feb 10, 2015.

  1. gowild2000 macrumors newbie

    Joined:
    Feb 10, 2015
    #1
    Have a Canon MG5420 wireless printer/scanner. A few days ago, the scanner portion just disappeared and the MBA (2014) only sees the printer. I'm running Yosemite, have spoken to Apple support and no luck. Have downloaded the Canon drivers, reinstalled, fixed disk permissions, deleted everything relevant in the library folder, rebooted (x 20) reset the printer to factory defaults and still no luck. Anybody have a thought on what I might try next? The scanner is shared and used a lot so this hurts.
     
  2. motrek macrumors 68020

    Joined:
    Sep 14, 2012
    #2
    Try plugging it in (USB) and see if that resets something?
     
  3. gowild2000 thread starter macrumors newbie

    Joined:
    Feb 10, 2015
    #3
    Tried that and the scanner appears when the device is plugged in via USB but disappears once it's unplugged. Thanks for the suggestion.
     
  4. coops macrumors regular

    Joined:
    Sep 10, 2009
    #4
    I've had a similar issue with my Epson all-in-one... a pain in the a@s driver issue.

    Found out you don't need to use the printer driver or scanner app -

    Look in your Apps and use 'image capture' app - this'll find your scanner wirelessly, and there you go. Scan to PDF or whatever.
     

Share This Page