Lots of system overloads in logic, new HD?

Discussion in 'Digital Audio' started by fikkser, May 9, 2010.

  1. fikkser macrumors member

    Joined:
    Oct 20, 2008
    #1
    I keep getting alot of system overloads in Logic 9. I got a unibody macbook pro late 2008 with 2,4ghz, 4gb ram and a 250gb 5400rpm.

    I usualy got around 30 tracks in logic. I mainly get the overloads when pressing play or when I browse other applications wile it's on play. Sounds like the hard drive?

    When the mac was new I never got overloads. But then I used logic 8 and osx 10.5, now I got logic 9 and 10.6.

    I'm more of a PC user and don't know how to maintain my mac in good shape, I've never done a clean install since 2008 and all I have done so far is to upgrade from 10.5 to 10.6. Can I do some kind of defrag as in windows? What should I think of to get best possible performance in Logic?

    I was thinking about getting a 500gb hd instead of this one if I cant fix my current hd, but I'm not sure if I should get 5400 or 7200 rpm. I read that a bigger hd gets better performance because of the higher density of data and that a 500gb 5400rpm should beat a 250gb quite well. But it may as well be bulls...

    Thankful for answers!
     
  2. wilycoder macrumors 6502

    Joined:
    Aug 4, 2008
    #2
    have you tried freezing some tracks in the project?
     
  3. newuser2310 macrumors regular

    Joined:
    Feb 16, 2010
    #3
    OSx uses up lots of virtual memory so lots of free hd space helps. Closing other apps when using logic will also help.


    If you have plenty of free space and maybe do a fresh install of osx and still find things slow. A new hd might be the way to go. You want the 7200rpm or a ssd for audio work.
     
  4. Comma macrumors member

    Joined:
    Feb 8, 2010
    #4
    Do you Freeze Tracks?
    Do you use a lot of plug-ins?
    Do you bus your reverb/delay?

    Probably close everything else when you're using Logic anyway, it lets you be more productive. Additionally, maybe upgrade your HDD, or have your current one less cluttered.
     
  5. dLight macrumors member

    Joined:
    Mar 11, 2008
    #5
    Which buffer setting do you use?
     
  6. deej999 macrumors regular

    Joined:
    Apr 1, 2009
    #6
    As mentioned above - Increas Buffer I/O Size when mixing. Decrease it when recording -
    Preferences : Audio : Devices

    OSX doesn't need to defrag. Unlike windoz it should do it all automatically. Try a repair permissions. in the Disk Utility application on your Mac.

    Have at least 15% free space on system drive.

    Use a firewire 7200rpm external drive to run projects from.

    Place shared effects like reverbs on Aux and send to them like mentioned by someone else.

    deej
     
  7. fikkser thread starter macrumors member

    Joined:
    Oct 20, 2008
    #7
    Thank you for responses.

    Works better now. But I should probably get a 7200rpm hd.
     

Share This Page