Loud click, no fan reading and quiet clicking

jaredelguay

macrumors newbie
Original poster
Nov 14, 2009
28
1
I turned on my uMBP today and took it over to my bed, and when I set it on my lap, there was a loud click noise (louder than the normal motion sensor click) and then a quiet clicking noise started up in the left corner. I took a look at the iStat reading and it said 0 rpm for the fan. I'm assuming that the fan just gave out.

I took it in to an authorized service provider and he said that he is "concerned that it could be the hard drive." Does that makes sense to anyone?

Regardless, it's well under warranty. But now I'm stuck using a crappy PC until I get it back and i'm already in withdrawal!
 

drtech

macrumors newbie
Dec 7, 2009
25
0
When you say "left corner", do you mean toward the front of the computer or toward the back (screen)? On most uMBP (with the exception of the 17") the hard drive is toward the front right. The 17" has it front left. The fan is basically back middle on some models, and back middle and back left (2 fans) on others.

It really depends on your uMBP model and vintage.

Does the mac still run? You say that you are stuck with a PC (I feel for you!), but also said that the mac continued to run after you heard the noise (ran iStat). If it was a continuously clicking hard drive, the Mac would probably just quit right there.

Jeff
 

jaredelguay

macrumors newbie
Original poster
Nov 14, 2009
28
1
The noise was coming from the middle/leftish of the back. And it still was running. That's why I assumed it was the fan. I think the tech I dropped it off with was crazy. If it was the hard drive, I'm certain it wouldn't have turned on.
 

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.