Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Loud pop and dead

heyharris1

macrumors newbie
Original poster
Feb 11, 2019
8
1
Looking for advice on a mid 2011 2.7ghz I5 IMAC running high sierra. I was right in the middle of working with Affinity Publisher (BETA) when the computer made a loud pop then shut down. Now it does nothing, wont boot up, makes no noise, dead to the world. Any advice on where I should look, what to check, or just can the thing and go back to a PC.

Thank you all,

Jim.
 

keysofanxiety

macrumors G3
Nov 23, 2011
9,534
25,267
Sounds pretty ominous. You can try SMC reset but I’m not sure it’ll help.

Unplug power from back of iMac (not the mains). Wait 15 seconds. Plug it back in. Wait 5 seconds. Try to turn it on again.

Try change the fuse too. Beyond that... :(
 
Comment

heyharris1

macrumors newbie
Original poster
Feb 11, 2019
8
1
I did not smell anything burning, already got the power supply out now and do not see any capicators exploded. Where is the fuse located at
 
Comment

heyharris1

macrumors newbie
Original poster
Feb 11, 2019
8
1
update, I checked the 4 lights led 501-504 and not of them light up when the machine is plugged in or even when I push the power button. Is this a sign the Power supply is dead.
 
Comment

heyharris1

macrumors newbie
Original poster
Feb 11, 2019
8
1
Quick update: Got new power supple and plugged it in and tested it with the lights and it came on as should. Plugged everything in and I am now back in business. In the 20+ years of working with computers I have never had a power supply go bad. When i bought this one I added the three year warranty as well just in case.

Jim
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.