Low-level Drive Reformatting Issue

Discussion in 'Mac Basics and Help' started by THX1139, Dec 27, 2009.

  1. THX1139 macrumors 68000

    THX1139

    Joined:
    Mar 4, 2006
    #1
    Hey, thanks for reading my post.

    Summary: I'm trying to do a low-level reformat of two identical drives. One took 2 hours to complete and the other says it will take 14 hours... and it's already been going for 3 hours. Why the difference?

    Longer version: I have two identical drives from the same manufacturer that I use in RAID-0 for Photoshop and Video scratch. A few months ago, one of the drives started to act up and I got an I/O error message. I broke up the RAID and reformatted the drives but never put them back into RAID; I wound up using them individually as short term storage drives. After I reformatted them, they both passed drive tests and there has been no problems since.

    I usually do computer house-keeping over the holidays and decided to put the two drives back into RAID-0 for a fast scratch disk (I don't store longterm data on them). I have a big project coming up and need a fast scratch disk. Anyway, I decided to zero out the disks to make sure any bad blocks that have deveoped over time are mapped out. The first drive zeroed out in a bit over 2 hours. The second has been going for 3 hours and it says that it's going to take 14 hours more! I thought that maybe I selected the more advanced reformat that requires multiple passes so I stopped the formatting to double check. Nope, it's set on basic one pass zeros.

    Sorry for the long post, but does anyone know what might be going on here? Do you think the drive is defective? I ran a simple reformat and drive check before I started the low level format and the drive passed. Even if it passes the reformat, I'm left wondering if there is a major issue with the drive that isn't showing up in tests. 16 hours++ to zero out a 320GB drive is insane! Especially when the other exact model drive only took 2 hours.

    Thanks for any insight you can provide!
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Do you know if it's the same drive that gave you the I/O error? You're right, it sounds like the drive may be on its way out. I had the same problem with my laptop hard drive a couple of days ago, so I expect I won't have a whole lot of life left in it. Fortunately everything I do on that computer is instantly backed up on Dropbox, but it's rather unnerving anyway.
     
  3. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #3
    That sure does sound suspicious. Since a full-zeroing of a drive (it's a little unfortunate how "format" has worked its way into the lexicon, since true low-level formatting is done at the factory and is inaccessible to the end-user) writes to every sector on it, if the drive has problems or is failing it will stall repeatedly when it hits a bad sector and needs to remap it. Since it's the drive's firmware doing it, the app doing the format doesn't notice apart from it taking a long time, and so long as the number of remapped sectors is below whatever threshold the manufacturer set, it won't fail the SMART test, either.

    You might well be able to hear what's going on if you listen--most drives I've had that have bad sectors do a similar repetitive-click sound when remapping them (or attempting to salvage data from them, which shouldn't be happening on a zeroing pass). Since a zeroing is completely linear usually you don't hear anything other than the motor spinning, so if it periodically ticks or grinds, that'd be a pretty sure sign that it's having problems.
     
  4. THX1139 thread starter macrumors 68000

    THX1139

    Joined:
    Mar 4, 2006
    #4
    I'm not hearing any clicking or grinding. But I also have 3 other drives in there that might be affecting the acoustics. Though, it's relatively quiet when I'm not doing anything with my mouse.

    I think what I'm going to do is run some surface scans once the drive finishes initializing and see what happens from there. The drive is still under warranty so if if fails, I can always send it in. I'm not too concerned about data loss cause I'm just going to be using it as part of a RAID set for scratch. I kind of hope it fails so that I can justify sending it in for replacement.

    I think it might be the same drive that caused the I/O errors a few months ago, but I can't be positive.

    Thanks for your replies. Good information!
     

Share This Page