lpadmin & Printer password prompt

Discussion in 'Mac OS X Server, Xserve, and Networking' started by christian2006, Jul 14, 2009.

  1. christian2006 macrumors newbie

    Nov 29, 2008

    A user has an issue where they are prompted for a password for the lpadmin. Now this user has a mobile home account and there are networked printers. No managed printers or queues.

    I know this changed in 10.5.7 and this support doc on Apple.com http://support.apple.com/kb/HT3511 says to add the user to the group. However this is no good as I want to stop it happening. The user should never be prompted for a password regarding printers.

    Has any one else had this issue?

    I believe it is down to the fact that the user switches between networks. The printer queue becomes paused and then to resume the printer it is prompting for a user/password that is a member of the lpadmin group.
  2. manowarwi macrumors member

    Oct 14, 2008
    I ran into this problem as well. I ran a slightly modified version of Apple's KB which adds everyone who is an administrator to the lpadmin group:

    dseditgroup -o edit -p -a admin -t group _lpadmin

    I used ARD to push it out to all of my clients. It seems to have fixed the problem for our institution.
  3. christian2006 thread starter macrumors newbie

    Nov 29, 2008


    I found this same article on Apple eventually. It seems to work. Thankfully the user in question can have admin rights. This is still very annoying as not all user can be made admin. So when a printer gets paused for some reason they are unable to resume it with out an admin password.

Share This Page