LTspice standard.dio library translation from Windows to Mac

Discussion in 'Mac Programming' started by nuhriko, Sep 28, 2015.

  1. nuhriko macrumors newbie

    Sep 7, 2015
    So I received a fortran 90 program file and a c program file from my professors and they ask me to study about it. These programs were designed such that they will call LTspice from the c program, which is then called by fortran. Since they programmed it in Windows, the first challenge was to modify all the directories for my PC, whose OS is Mac. Now after modifying all of the directories written on the program, from the log file generated after the program run, I get this error:

    Fatal Error: Could not open library file "C:\PROGRAM Files\LTC\LTSPICEIV\lib\cmp\standard.dio"

    Now, I could not trace where I should fix the error in fortran and c codes because I do not see any line related to standard.dio, which contains all the component models definition for LTspice.

    One workaround that I tried is placing the SPICE statement below, thinking it may override the default library file directory called:

    .inc /Applications/

    But it still produces the same error. So my question is, where exactly should I fix this problem? I'm not even sure if this is a Mac-based issue but I am asking the same question to SPICE forum just in case. Should this be fixed in the c program or somewhere in LTspice? Thank you very much!

    For reference, kindly see the uploaded screenshot.

    Attached Files:

  2. nuhriko thread starter macrumors newbie

    Sep 7, 2015
    Problem solved, the relevant LTspice net files called by the C program contains a line concerning the standard.dio location. In the net files, replace

    C:\PROGRAM Files\LTC\LTSPICEIV\lib\cmp\standard.dio



    for Mac OS. Thanks and sorry for occupying thread space but I hope it can be helpful for others.

Share This Page