M-Audio Keystation Pro 88 w/ Leopard

Discussion in 'Digital Audio' started by jude4312, Dec 20, 2007.

  1. jude4312 macrumors newbie

    Joined:
    Dec 4, 2007
    #1
    hi, i have iMac 24" 2.8Ghz 4GB RAM
    i use garageband and logic express 8 for recording.
    under leopard, my keyboard controller is not recognized.
    this is class-compliant, meaning there's no particular driver for this.
    however, i have been working fine with it on tiger.
    if anyone one had similar problem and found solution to it, please share it with me, thanks.
     
  2. watersb macrumors newbie

    Joined:
    Dec 30, 2007
    #2
    The M-Audio web site says this keyboard isn't supported on Leopard yet.

    BUT it WORKED for ME!

    I've installed the most recent Leopard Software Update and my Keystation Pro 88 just worked with GarageBand 08.

    I haven't tried all the knobs and switches but the basic keyboard works fine, and the pitch and modulation wheels, too.

    I ran Enigma 1.2.2 and it seems to recognize this keyboard.

    FWIW this is on a first-generation MacBook Pro.
     
  3. jude4312 thread starter macrumors newbie

    Joined:
    Dec 4, 2007
    #3
    my leopard is up to date and it's still not working..
    it says there may be a possible conflict in midi drivers.
    is that all you did to make it work? just installing the software updates?
    did you have problems like this in prior to the software updates?
    thanks.
     
  4. watersb macrumors newbie

    Joined:
    Dec 30, 2007
    #4
    I am being simple, I suppose: I only use the keyboard as an input device to GarageBand via the USB interface. It is a clean install of Leopard - no third-party drivers of any kind.

    I have not used the MIDI ports on the back of the keyboard (the standard DIN connectors). When GarageBand is running, if I turn the keyboard on it says "the number of MIDI inputs has changed".

    I wish I could provide more info, but in any case the keyboard seems to work with a clean install of Leopard with no third-party drivers.
     
  5. pierce higgins macrumors newbie

    Joined:
    Jan 17, 2008
    #5
    follow up

    Hi
    i don't know if you have solved your problem yet but I just received a keystation Pro 88 and linked it to my Macbook (leopard installed over Tiger) with Garageband 3.0.5. I connected with USB and just followed instruction in Quick start. However I first checked in Applications/Utilities/Audio Midi set up/Midi devices to ensure that the mac was seeing the keystation...which it was. Then it worked.....I chose in garageband a track (piano) played key on keyboard and sound was played through the mac. i haven;t done anything else yet.
    regards
    Pierce
     
  6. tightpants macrumors newbie

    Joined:
    Mar 18, 2010
    #6
    Mac problem with pro 88 keystation

    Hi there - I am having a similiar problem. I am running the keystation pro 88 with protools with a mbox sound card. I am getting no sound at the moment. When I plug in my oxygen 8 - maudio it works no problem. Does anyone know what I am doing wrong ? Thx kindly. T
     

Share This Page