M.B.P. Hard drive wont mount......PLEASE HELP ASAP!!!

Discussion in 'MacBook Pro' started by MacNoob1995, Jul 25, 2013.

  1. MacNoob1995 macrumors newbie

    Joined:
    Jul 24, 2013
    #1
    Hey there this is my first post ever on any form in my whole life so if I'm in the wrong area I apologize.


    So the reason I'm here. I have a M.B.P/w a 320gb hitatchi hd, as well as 2 others a 500gb seagate (out of my late 2011 mbp) and a 2tb w.d. as a back up.

    So I will give you a quick story of what happened. I had the 500gb hd in the computer via internal sata cable. I then put it into a sleep mode (instead of shut down by accident I'm sorry it was 5am) So then when I woke up I switched out to the 320gb and then flipped it over and went to turn it on when to my shock it woke up and the desktop was still on the 500gb. once i realised what i had done i instantly turned the computer off by pressing and holding the power button(I know stupid but i freaked out). I then turned it back on and it went into recovery mode and now I cant even mount the 320 gb when im in recover mode via any hard drive or boot disks.

    So I went into disk utility and tried to repair the disk but it says
    Verify and Repair volume “Macintosh HD”
    Checking file systemChecking Journaled HFS Plus volume.
    Checking extents overflow file.
    Unused node is not erased (node = 187)
    Checking catalog file.
    Invalid sibling link
    Rebuilding catalog B-tree.
    The volume could not be repaired.
    Volume repair complete.Updating boot support partitions for the volume as required.Error: Disk Utility can’t repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files.


    So I looked online but the only thing i can find is the dd command and I am way to amateur to understand it. I keep getting hung up on ("some_dir").

    OH and I forgot to mention this is my sisters computer, she is going to kill me if I cant save every file on it so any help would be awesome as I'm flat broke at the moment so taking it to a shop is out of the question.
     
  2. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
    #2
    The obvious question. Have you tried putting the 500GB back in? If it boots shut I down properly and try the 320GB again.
     
  3. MacNoob1995, Jul 25, 2013
    Last edited: Jul 25, 2013

    MacNoob1995 thread starter macrumors newbie

    Joined:
    Jul 24, 2013
    #3
    ok i tried that and no luck thanks tho

    p.s to clarify the 500 boots fine the 320 still wont mount
     

Share This Page