m.youtube.com -- can't close the "you have the app" notification

Discussion in 'iPhone' started by joeyconnick, Dec 22, 2012.

  1. joeyconnick macrumors newbie

    Mar 10, 2007
    So, iOS 6, iPhone 5

    I often open m.youtube.com in Safari instead of using the YouTube native iOS app because the mobile site has an option to show the HD versions of videos and the app was showing the low quality version without any option to switch (I assume because I was on cellular data because right now on wireless it's showing the HD version).

    Anyway, the mobile site is smart enough to know I have the app on my phone and it ALWAYS displays this super-annoying banner at the top of the page with the option to open the app. The banner has a little X that I assume should banish, hopefully forever, this dumb banner (see attached image).


    My problem is that for the life of me, I CANNOT seem to hit the X. Everytime I try to, the phone thinks I've clicked the full banner and opens the bloody YouTube app, which is the opposite of what I want to do.

    Am I doing something wrong? Is there a bug and you can't close this banner on the YouTube mobile site? I seem to recall other mobile sites with the same types of banners and having been able to get them to go away but I've tried dozens of times in both portrait and landscape orientation and it just won't "take."

    Is there some alternate way to get rid of these annoying banners?

    Any help is welcome!
  2. austinguy23 macrumors 6502a

    Oct 8, 2008
    I have the same problem and it started when I got my iPhone 5 though that's likely unrelated.

    It could just be a marketing trick to get people to install the app.

    It's not just the YouTube site though. I've seen the same problem on other sites.
  3. SomeDudeAsking macrumors 65816

    Nov 23, 2010
    That banner is created by Apple, not YouTube. It's an Apple bug.....again.
  4. pickaxe macrumors 6502a

    Nov 29, 2012
    Just tried it myself and was unable to close it as well. Ridiculous. Did Apple even beta test this at all?
  5. HazyCloud macrumors 68030


    Jun 30, 2010
    On a related note, I was unable to close the Netflix notification earlier today. I tried hitting the 'X' multiple times, but it kept launching the app.
  6. bgro macrumors 65816

    Jul 6, 2010
    South Florida
    Had the same problem and finally just reverted to using the app again because it was annoying as hell

Share This Page