Mac 10.4.10 Operating System; IMovie 4.0.1 Help!

Discussion in 'Mac Basics and Help' started by letsgobowlingx, Feb 10, 2010.

  1. letsgobowlingx macrumors newbie

    Joined:
    Feb 10, 2010
    #1
    My boyfriend just dug out his old Mac to start editing videos again. However, the camera he has is an old Sony Handycam without a firewire connection. I'm looking to find the best solution while spending the least amount of money possible (eventually upgrading everything.) Either upgrading the camcorder or the software first. I'm not sure what versions of Imovie are compatible seeing as the Mac software is pretty old. Or what cameras are compatible with the old IMovie. Sorry if this is confusing, I've been trying to research this for days now and don't know much about Macs!

    Thanks for the help!
     
  2. John Doe 57 macrumors 65816

    John Doe 57

    Joined:
    Jan 26, 2008
    Location:
    Los Angeles, CA
    #2
    For starters, it might be a good idea to run Software Update to bring the Mac to 10.4.11 and also to see if there are any updates for iMovie. I'm not sure if iMovie 5 or 6 will show up in Software Update because you might have to buy iLife '05 or '06 instead. In my opinion, iMovie 6.0.3 was and is still to this day, the best version of iMovie ever made. iMovie '08 doesn't compare. I've been using it since 2006 and it has been a great easy-to-use tool for quick film projects.

    As for the camera, this may help:
    http://forums.macrumors.com/showthread.php?t=834095
     

Share This Page