Mac and iPhone unable to connect to open wifi

Discussion in 'Mac Basics and Help' started by memco, Jun 25, 2009.

  1. memco macrumors 6502

    Joined:
    May 1, 2008
    #1
    I have an open wifi network setup that I can't connect to. There are several PC users in the house able to connect, but my iPhone and MBP are unable to establish a connection. Stranger, is that when I plugged into the ethernet, my laptop was also unable to connect using the "Automatic location." I setup a new location and was able to use ethernet, but wifi is still not working. I used to be able to connect to the network and as far as I know no settings have changed. I've tried resetting the cable box, wireless router and the computers, and I also tried dumping all network related preferences I could find.

    Any help is appreciated.
     
  2. silvermongoose macrumors newbie

    Joined:
    Jun 25, 2009
    Location:
    Milton Keynes, England
    #2
    Iphone wifi problem

    Sorry I can't help. However, I am now on my 3rd handset and each one has the recurring fault of not recognising my wifi router. The latest handset (got it on Monday 22nd) was fine to start with but decided yesterday that it wasn't going to find any wifi network / router / hotspot or cloud let alone my home one! I have literally tried everything. Restart, restore network settings, restore the phone from backup, restore the phone from scratch delete temporary files in the itunes programme files then restore the phone 'as new' (i even downloaded the 3.0 OS fresh from start). nothing has made any difference. I can't believe I'm unlucky enough to get 3 handsets all with the same fault???? will re-post if I find anything out.:confused:
     
  3. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #3
    um... wondering what kind of wifi it is? 11.b? maybe the Mac doesn't match the type. Check the wifi type?
     
  4. memco thread starter macrumors 6502

    Joined:
    May 1, 2008
    #4
    I believe the router is pushing out 802.11g. I'm running a 2.4ghz MBP, which supports g just fine AFAIK. Also, I've connected to this network before so it's not a hardware incompatibility (though it may be a hardware problem).
     
  5. keithOrbit macrumors member

    Joined:
    Apr 22, 2008

Share This Page