Mac App Store Binary Rejection Question

Discussion in 'Mac Programming' started by Avizzv92, Apr 15, 2011.

  1. Avizzv92 macrumors regular

    Mar 23, 2008
    I had to change my application's name, it led to a rejection; after changing the name and the respective build settings I submitted the new binary to the Mac App Store with Xcode 4. Xcode uploads it without problem but a few minutes later the binary will be rejected with this message:

    I triple checked the build settings, and they were the same ones (except for the Product Name) as the initial binary that worked. Would anyone have insight as to what may be causing this problem? I checked the Target's "Architectures" and "Valid Architectures" settings and they are correct. I ran
    lipo -info
    on the Unix Excutable File and I got x86_64.

    By an off chance, would the fact that my app ends in an '!' cause problems? i.e."MyApp!.app"

    Does Apple require you use the latest Xcode version? I have 4.0.0 not 4.0.2.

Share This Page