Mac App Store, Failed to Download, Use the Purchases Page to Try Again

Discussion in 'Mac Apps and Mac App Store' started by DavoteK, Oct 26, 2013.

  1. DavoteK macrumors 6502

    Joined:
    Jan 5, 2012
    #1
    The error message (as seen in the attachment) I am getting for updates, previous and new purchases on my MBPr, just after upgrading to Mavericks.

    I have cleared the cache for the Mac App Store, force closed the app store process, deleted any apps that had this error, rebooted, ensured there are no firewalls blocking connection to the app store (removed them all). I've tried with two different Apple IDs, same result.

    Can normally find the issue in these forums, but I'm coming up blank on this one.

    Any other ideas?
     

    Attached Files:

  2. geveke macrumors newbie

    Joined:
    Jan 17, 2007
    Location:
    Utrecht, the Netherlands
    #2
    You've probably replaced iTunes 11 with iTunes 10.7. Somehow this breaks the App Store - not right away, but after a reboot it's impossible to do any downloads from the App Store with iTunes 10.7 installed on Mavericks... Very annoying, since I definitely don't want iTunes 11.
     
  3. DavoteK thread starter macrumors 6502

    Joined:
    Jan 5, 2012
    #3
    First off, thanks for the reply man. Would probably still be trying to source the answer to this in a few weeks time.

    Second off, I don't mind iTunes 11, I use it on my MacBook to sync stuff to my iPhone, but have iTunes 10.7 on my iMac purely for iTunes DJ to allow guests to vote up/request tunes.

    Guess I'll have to install and uninstall when there is an update I need in the Mac App Store. Ballache lol.

    Anyway, thanks again man.
     
  4. bluegene macrumors newbie

    Joined:
    Dec 8, 2010
    #4
    Hi DavoteK,do you resolve the problem?
     
  5. DavoteK thread starter macrumors 6502

    Joined:
    Jan 5, 2012
    #5
    That I did. Turned out it was because I had downgraded my version of iTunes to 10.7.

    Upgraded to latest version of iTunes, problem resolved.
     
  6. vmflapem macrumors 6502

    Joined:
    Dec 27, 2013
    #6
    Wow Apple sure is the best company out there.
    First they introduce so many little bugs in the newest version of iTunes and now they're forcing everyone to use that newest version or we can't download anything from the App store.

    Great work Apple.
     
  7. cbqtixaa macrumors newbie

    Joined:
    Aug 16, 2016
    #7
    Just got the same issue. I couldn't upgrade to El Capitain because of the old Itunes. I just spent 2hours on the phone with apple support but they couldn't help at all.
    All that because if you buy the last Magic Mouse 2 you need El Capitain to use it. Great move Apple!

    I know this threat is from 2013 but this thing is still an issue.
     
  8. Hockenbury macrumors newbie

    Joined:
    Nov 21, 2011
    #8

    Hi cbqtixaa, I got the same "failed to download" error message with a couple of different app updates and an app re-install. After spending a couple of hours investigating it, I hit upon a combination of steps that worked for me. Here are the steps I followed:

    Step 1. Reinstall iTunes.

    Download and reinstall current version of iTunes (which is currently version 12.6.2). Here is the link: https://www.apple.com/itunes/download/

    Step 2. Change your DNS setting.

    Here’s how to do that: Go to Network Setting in Settings Preferences. Select your network connection, click Advanced in the lower right-hand corner, then click DNS in the top row of options. At the bottom of the left side pane titled “DNS Servers:” click the plus (+) button and 0.0.0.0 should appear as the first line in the window. Type over it and change DNS to a different setting.

    One possible DNS setting is Google’s 8.8.8.8 or 8.8.4.4 DNS settings. You could also insert one of these OpenDNS settings: 208.67.222.222 or 208.67.220.220 on the first line.

    Just for the record, I used a different Cox Communications (my Internet provider) DNS setting: 68.105.28.11

    Step 3. Clear the App Store cache.

    Open the Terminal utility (in the /Applications/Utilities/ folder) and run the following command:

    open $TMPDIR/../C

    A Finder window will appear that shows a number of folders. Locate and delete the folder named "com.apple.appstore," then empty the trash.

    Re-start your Mac, allow all background startup processes to finish, then try launching the App Store and purchasing or updating the application again. Hopefully, it will download and install without any error messages.

    Step 4. Optional: Clear the DNS setting you previously set.

    It’s no big deal if you leave the DNS setting you selected but if you want to restore the default setting, simply repeat the steps in Step 2 above. Click on and highlight the DNS setting you previously typed in, then hit Delete. Close the windows and your network settings will automatically reset to the default settings (which on my Mac is to default to the Airport Extreme setting: 10.0.1.1). You may possibly have to restart your Mac.

    These are the steps I followed on four out of five Macs that gave me the App store "failed to download" error for different updates and app re-installs. These steps worked for me and I hope they work for you. Good luck!
     

Share This Page