Mac App Store fails to load completely - MBA 11"

Discussion in 'Mac Apps and Mac App Store' started by djp2, Jan 29, 2011.

  1. djp2 macrumors member

    Joined:
    Jan 16, 2010
    #1
    I just bought a new MBA 11", and downloaded all of the available software updates as soon as I got it set up at home. Among the available updates was Snow Leopard 10.6.6 with the App Store. Unfortunately, whenever I try to open the App Store it either

    a) fails to load at all - just gives a blank loading screen

    b) loads only 50% and leaves the top tabs (Featured Apps, New Apps, etc.) completely greyed out and unclickable, along with the search bar which is unclickable, or

    c) occasionally, loads normally.

    So far, I've tried repairing permissions in OS X, downloading and installing the 10.6.6 "combo update" from Apple, and contacting Apple Support (they're closed tonight).

    I thought I'd check here to see if anyone else has experienced this problem, or if anyone has ideas on how I might fix it. I'm new to Macs so I don't really know my way around troubleshooting Mac applications. Can I delete Mac App Store and reinstall it? I'd really like to not have to format and start over from scratch, since I spent a lot of time earlier importing my iTunes library, photos, etc.
     
  2. JamesMB, Jan 29, 2011
    Last edited: Jan 29, 2011
  3. djp2 thread starter macrumors member

    Joined:
    Jan 16, 2010
    #3
    Ah, thanks for finding those. I'm pretty new to posting here...I did a search but didn't see either of those!

    In any case, it looks like people are solving the problem by formatting the HD and starting over again, making sure to sign into iTunes and download an app BEFORE installing the software update with 10.6.6. Reformatting is exactly what I was hoping to avoid but I guess I have no choice!
     
  4. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #4
    Look at the second link that I sent you. If that doesn't work, I would call Applecare before I formatted my HDD. Surely they have had calls about this and have a better solution than formatting.
     
  5. techpr macrumors 6502

    techpr

    Joined:
    Sep 9, 2008
    Location:
    San Juan, PR
    #5
    You may want to try this to fix the Mac App Store loading problem. This worked for me and my App Store works OK since.

    http://pbagwl.tumblr.com/post/2873882667/mac-app-store-fix-one-moment-please
     
  6. djp2 thread starter macrumors member

    Joined:
    Jan 16, 2010
    #6
    Thanks both JamesMB and techpr for the suggestions. I tried both methods, and now it seems that the App Store will load almost every time (almost), but only after about 3 or 4 minutes of sitting there blank and grey. I'm guessing that's not a normal wait time. Looks like I'll be giving Apple a call tomorrow!
     
  7. djp2 thread starter macrumors member

    Joined:
    Jan 16, 2010
    #7
    Also, it still seems to be loading funny, even when it does (eventually) load. The search box is greyed out, and the tabs at the top are usually greyed out. Sometimes the main "splash" image on the front page will appear all glitchy and the images will repeat all the way down the page. Very strange bug. I did a quick search on Apple's support forums and found that many people are having trouble with this...Apple doesn't seem to know the cause of the problem yet.
     

Share This Page