Mac App Store Updates not automatically working

Discussion in 'OS X Mountain Lion (10.8)' started by phillytim, Oct 8, 2013.

  1. phillytim macrumors 6502a

    phillytim

    Joined:
    Aug 12, 2011
    Location:
    Philadelphia, PA
    #1
    Greetings!

    Seems like I have to press the "COMMAND+R" combo, everytime I go to the Updates section of the Mac App Store, for available updates to checked properly.

    Third-party updates do seem to show up automatically, but not Apple-branded system/software updates tho (might be coincidental).

    I never know when an update is released unless I follow the Mac news (such as a new version of iTunes) and then go to the App Store Updates section and press COMMAND+R.

    I mainly use a regular user account, but have an Admin account to authenticate with whenever major changes/installs happen on my OS-X 10.8 based 2011 MBPro.

    I have upgraded the hard drive earlier this year, which was about the time this issue began happening. I did a partial Time Machine restore (only my regular user account & data, if I correctly recall) onto the new hard drive & install of OS-X 10.8.

    Any advice how to get Mac App Store Updates to be automatically checked for as their suppose to be?

    Thanks, in advance!
     
  2. hamsterdam macrumors newbie

    Joined:
    Oct 8, 2013
    #2
    I am having the same issue, except refreshing the App Store doesn't bring up the updates. I've been having to download them all manually through Apple's download page. Quite frustrating. I've re-indexed spotlight, which seems to be the primary solution offered on various forums, but this did nothing for me.
     
  3. phillytim thread starter macrumors 6502a

    phillytim

    Joined:
    Aug 12, 2011
    Location:
    Philadelphia, PA
    #3
    Yeah I've re-indexed Spotlight too; still no go.

    Another article had me delete some Library cache files for the "store", in an attempt to reinitialize everything, but that didn't seem to help either.

    Anyone else have advice?
     
  4. sjinsjca macrumors 68000

    sjinsjca

    Joined:
    Oct 30, 2008
    #4
    Here's what works for me.

    First, my daily-driver user account is a non-Admin account, which is a good security practice.

    So in my case, the problem of updates not being found can be worked-around by momentarily logging into my Admin account, and doing the look-for-updates there.

    Once that's done, I can either update from the Admin account, or switch back to my user account and run the look-for-updates there. That seems to unjam it.

    There's a Terminal command you can run, but this has worked as well for me.

    I'm hoping the issue goes away with Mavericks...
     

Share This Page