Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Super Xander

macrumors 6502
Original poster
Nov 6, 2016
290
107
Denmark
Hey. I've got an issue where my the AppStore on my Mac is stuck updating apps. It tries to update but are just stuck on the update and never installs. I'm on Big Sur 11.1, MacBook Pro 16.

I've tried to restart my computer, logged in and out of AppStore and tried to find solutions on the internet but nothing seems to work.

Anyone with same experience or have an idea for a solution?

Thank you!!
 
  • Like
Reactions: Heavy Dude

Heavy Dude

macrumors newbie
Sep 25, 2009
17
1
I have the same issue. Started last week all of a sudden on 11.1

Updating to 11.2 haven't solved it..
 

ghanwani

macrumors 68040
Dec 8, 2008
3,234
3,606
I'm on 11.2.3 and the installer has been trying to install Pages for the last several days without any progress.

I'm thinking of killing the installer process. It's chewing up a lot of CPU and causing the machine's response to slow.

Edit: A reboot fixed it.
 

Attachments

  • Screen Shot 2021-03-30 at 9.23.22 PM.png
    Screen Shot 2021-03-30 at 9.23.22 PM.png
    36 KB · Views: 19
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.