Mac BF2142 Widescreen Fix

Discussion in 'Mac and PC Games' started by meanderis, Sep 11, 2007.

  1. meanderis macrumors newbie

    Joined:
    Sep 11, 2007
    #1
    Took me a little bit to figure this one out.
    If you want to enable widescreen support ( and maybe better resolution )
    Open up in your favorit text editor "~/Library/Preferences/Battlefield 2142 Preferences/config" and at the bottom of the file add these lines

    Code:
    [AppDefaults\\BF2142.exe\\transgaming]
    "cmdlineadd" = "+widescreen 1 +szx 1440 +szy 900"
    
    If all goes well you'll be in widescreen mode but I haven't bothered to confirm if the resolution has changed yet. Just wanted to get this out there asap.
     
  2. kkat69 macrumors 68020

    kkat69

    Joined:
    Aug 30, 2007
    Location:
    Atlanta, Ga
    #2
    I tried it and no go. Was a noble effort but it defaulted to what was specified in :
    "DefaultScreenWidth" = "800"
    "DefaultScreenHeight" = "600"

    and I can confirm changing that to anything it doesn't understand causes it to crash.
     
  3. meanderis thread starter macrumors newbie

    Joined:
    Sep 11, 2007
    #3
    You might want to verify that you the +szx and +szy to valid values for your computer. It's nice not having the black bars on the sides of the screen when I play bf2142. Video config always says its at 1024x768 so I'm not 100% sure that the resolution changes are happening but it's definately widescreen for me. I'll have to check if there where any other changes that are still there. ( I may just remove my preferences and start it back up and make the changes from scratch tonight and then test lower resolutions to make sure the resolution changes.)
     
  4. kkat69 macrumors 68020

    kkat69

    Joined:
    Aug 30, 2007
    Location:
    Atlanta, Ga
    #4
    They are valid for my PC. I didn't use your values, I used resolution values per my screen.

    Previous statement still stands, it's a no go on my end.
     
  5. Slobs macrumors newbie

    Joined:
    May 29, 2003
    #5
    I know this is an old thread but it's the only place I found good info on BF2142 Mac widescreen.

    For what it's worth the above method worked perfectly to enable 1440x900 widescreen on my Mac.
    Specs:
    2.16GHz Core Duo MacBook Pro
    2GB RAM
    256MB Radeon x1600
    Leopard 10.5.2 fully updated as of 06MAY2008
    BF1942 Patch 1.40

    Hopefully this info can continue to help others as it's particularly terrible to have to play it in 1024x768 scaled on a widescreen LCD.
     
  6. kkat69 macrumors 68020

    kkat69

    Joined:
    Aug 30, 2007
    Location:
    Atlanta, Ga
    #6
    Yah it was pretty old. I am pretty active on those forums (at least until recently when I left since I don't play anymore)

    And I posted a while back that the problem was indeed copy and paste as one EA Forums user posted. Copy and Paste adds some ASCII chars that causes the widescreen fix to not work.

    It's not hard to manually type the settings in the config file. I posted in the EA Forums that once I did that it worked great. I run at 1344x840 windowed and 1920x1200 full screen.
     
  7. masterpilot macrumors newbie

    Joined:
    Jul 24, 2008
    #7
    Worked perfectly to enable 1440x900 widescreen on my Mac!!!

    Specs:
    2.4GHz Intel Core Duo MacBook Pro
    4GB RAM
    256MB GeForce 8600M GT
    Leopard 10.5.4 fully updated as of 24JULY2008

    THANK YOU!
     
  8. shishk macrumors newbie

    Joined:
    Mar 28, 2009
    #8
    Heeeeelllllp!

    Ok

    i just bought the mac version of bf2142 from the store installed it into my brand new imac... and there is no widescreeen?

    how do i get it to 1900 x 1200?

    i have installed the latest 1.5 patch(which said widescreen was now available?) and even tried changing the config file as posted here. ive tried re install after reinstall.

    im really dissapointed as this is the first game ive bought for my mac.

    i dont even know that the patch has worked because i cant see the new maps.. the only thing to indicate it has loaded is the change in size to the bf2142 file.

    im just a little annoyed i paid alot of money for something thats not working at full spec. thanks alot EA :/

    i have a 24inch imac 2.8ghz with 2gig ram and 256mb ati pro so shouldnt have these problems.

    could someone please be kind enough to tell me what i need to do? as none of the suggested things have worked for me here.

    thanks
     
  9. katnoodle macrumors newbie

    Joined:
    Apr 27, 2006
    Location:
    Bath, UK
    #9
    I found a post on another blog which worked well for me.

    Open your 'library > preferences > Battlefield 2142 Preferences' folder and then open the config file in textedit (probably best to backup first).

    Then on a new line right at the end add:

    [AppDefaults\\BF2142.exe\\transgaming]
    "cmdlineadd" = "+widescreen 1"

    Save it , restart the game, and you should have widescreen modes in your graphic options. Worked for me.

    Original post here http://ianc14.livejournal.com/256132.html

    Kinda typical EA from my experience - getting a lot of gfx glitches too, and their support is pathetic.

    Hope this helps.
    Rich
     
  10. okboy macrumors regular

    Joined:
    Oct 9, 2010
    #10
    I seem to have problems with BF2142 with the new MacBooks Airs (2012, HD 4000). The screen just glitches out.
     

Share This Page