Mac Book 2015 with SolidWorks

peterpan123

macrumors 6502
Original poster
Sep 24, 2014
275
12
Hello, Has anybody used SolidWorks (3D CAD) on MacBook 2015? How is the performance? Thanks.
 

modernaccord

macrumors 6502a
Apr 20, 2015
620
197
Seattle, WA region
Don't expect much. I had a hard time streaming HD video from Netflix at the 1440 resolution. SW is a superb piece of software that ran great on my mbpr which got me through engineering school, but it's def not for the rMB. Save some cash and pick up a 13 rmbp for a task like that.
 

azzawaba

macrumors newbie
May 11, 2015
7
1
Hello, Has anybody used SolidWorks (3D CAD) on MacBook 2015? How is the performance? Thanks.
Hi

I have used SolidWorks with Parallels. Assigned 3 cores, 6 GB memory and about 75% on video card. Single part weldments (about 15-20 features) goes like a breeze. Small assemblies, not a problem. 2d-drawings are a bit slow for larger parts. I would not recommend using SW on this as main machine (unless you are working a lot with single parts and small assemblies)! For viewing and a little bit of work every now and than it is perfectly good enough. MB goes warm. Close all apps in osX before entering parallels. Probably you'll get better results than me by using bot camp
 

dyn

macrumors 68030
Aug 8, 2009
2,708
383
.nl
SolidWorks has high demands when it comes to cpu and especially GPU (ISV certified and such) which basically means that it won't run well on anything that isn't an ISV certified GPU from AMD or Nvidia.

Also, the Core M in the MB only has 2 cores. It can run 4 threads simultaneously though.
 

lhagan

macrumors newbie
Dec 20, 2009
9
1
I've run Solidworks 2013 in Parallels on my 1.3 GHz rMB quite a bit and haven't had any issues at all. I agree with
azzawaba -- don't use this as your main CAD machine -- but it's very usable for light CAD work on the go.

You do need to do some registry editing to get things running smoothly, though. If you don't, Solidworks may assume your video card can't do 3D and will use software OpenGL, which is really slow on just about any machine. Software OpenGL is to blame if you go to select something and it takes seconds (or even minutes) to highlighting all of the edges of the part in orange.

Assuming you're on Windows 7, enter "regedit" in the Start Menu's Search bar and hit enter. Then navigate to "HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2013\Performance\Graphics\Hardware\" and go to Edit > New > Key to create a new registry key. Name the key "Parallels and Intel Inc." and then go to Edit > New > DWORD (32-bit) Value and name the new value "Workarounds". Finally, double click on "Workarounds" and enter the value data "4000480" (leave Base as Hexadecimal). Start up Solidworks, and make sure that "Use software OpenGL" is unchecked in Tools > Options > Performance.

Also, turn off Real View, part shadows, and reduce "Level of Detail" in Tools > Options > Performance.

Edit: source for the registry hack is this Parallels forum posting https://forum.parallels.com/threads/opengl.114508/
 

sonicrobby

macrumors 68020
Apr 24, 2013
2,369
394
New Orleans
I've run Solidworks 2013 in Parallels on my 1.3 GHz rMB quite a bit and haven't had any issues at all. I agree with
azzawaba -- don't use this as your main CAD machine -- but it's very usable for light CAD work on the go.

You do need to do some registry editing to get things running smoothly, though. If you don't, Solidworks may assume your video card can't do 3D and will use software OpenGL, which is really slow on just about any machine. Software OpenGL is to blame if you go to select something and it takes seconds (or even minutes) to highlighting all of the edges of the part in orange.

Assuming you're on Windows 7, enter "regedit" in the Start Menu's Search bar and hit enter. Then navigate to "HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2013\Performance\Graphics\Hardware\" and go to Edit > New > Key to create a new registry key. Name the key "Parallels and Intel Inc." and then go to Edit > New > DWORD (32-bit) Value and name the new value "Workarounds". Finally, double click on "Workarounds" and enter the value data "4000480" (leave Base as Hexadecimal). Start up Solidworks, and make sure that "Use software OpenGL" is unchecked in Tools > Options > Performance.

Also, turn off Real View, part shadows, and reduce "Level of Detail" in Tools > Options > Performance.

Edit: source for the registry hack is this Parallels forum posting https://forum.parallels.com/threads/opengl.114508/
This is very helpful! Thanks!
Do you think the 1.1GHz model will handle it just as well?
Would you mind posting some videos showing how it handles manipulating small assemblies, large assemblies, and drawings?

Also, what peripherals do you use? A bluetooth mouse? Ive always been a fan of hard-wired peripherals because of their snappiness, but with the single port on the rMB I don't think it would be possible when charging.