mac book keyboard issues HELP!!

Discussion in 'MacBook Pro' started by crazy.fool, Dec 4, 2007.

  1. crazy.fool macrumors newbie

    Joined:
    Feb 13, 2007
    #1
    recently purchased a blackbook 2gb ram only a month old has worked perfectly until now. for some reason the keyboard turns it's self off if not in use the only way to get it to turn on again is to tap a key repetitively until it starts to type again. This is more off an annoyance than anything especially as you only have to be inactive on the keyboard for less than a minute.

    does anyone know of a cause to this problem? or heard of other people with this issue? i have my battery settings to optimise energy saving this wouldn't cause the keyboard to turn off if inactive though would it?

    i have apple care what would the general procedure be if i wanted to let apple have a look at the machine i need the quickest solution because im a student at university and my laptop is my lifeline.
     
  2. Hawkeye411 macrumors 68000

    Hawkeye411

    Joined:
    Jun 6, 2007
    Location:
    Canada EH!!!
    #2
    Had a problem with my keyboard. Turns out that it was a loose keyboard connection. I had to take it in for service. I can't imagine taking my MacBook apart myself but there are probably instructions somewhere on the web if you want to try to fix it yourself.

    Cheers.
    :):apple:
     
  3. kkat69 macrumors 68020

    kkat69

    Joined:
    Aug 30, 2007
    Location:
    Atlanta, Ga
    #3
    There are a boatload of people with this issue and a lot of posts.

    Both here and in the Apple Discussions. I'm sure you can find your way to these posts if you look so I won't post any links.
     
  4. crazy.fool thread starter macrumors newbie

    Joined:
    Feb 13, 2007
    #4
    thanks guys i had a quick look before i posted this but i obviously didn't look hard enough cheers for the quick responses.
     
  5. ccoulson macrumors newbie

    Joined:
    Dec 4, 2007
    #5
    Apple is tracking a bug on this. It seems to happen only with MacBook/MacBook Pros with Intel processors and running 10.5.0 or 10.5.1. Sounds like a driver issue. Stay tuned for a fix (10.5.2?).
     
  6. moez macrumors regular

    Joined:
    Jun 6, 2007
    #6
    My MBP on 10.5.0 had the same issue (when ppl laughed at me :( ) anyways 10.5.1 seems to have fixed it. If u r using 10.5.0 Leopard try upgrading and see how that works.
     

Share This Page