mac book pro not booting up

Discussion in 'Mac Basics and Help' started by dsoreal, Mar 5, 2008.

  1. dsoreal macrumors newbie

    Joined:
    Mar 5, 2008
    #1
    Hi Guys

    I installed the latest security update on my mac book pro on thursday night. since then I've had nothing but bother, from word not opening due to a quicktime error, my CD drive wasn't recognised and now I am getting the following error.

    /etc/master.passwd: Invalid argument
    -sh: /etc/profile: Invalid argument
    -sh-2.05~ CSRHIDTransitionDriver::stop
    IOBluetoothHCIController::start Idle Timer Stopped

    grey screen loads at the start and then this error message appears. anyone got any ideas on how to resolve the issue. came home to get my installation CD's but they are no were to be found. anyone know where I can get replacement ones?

    Thanks in advance for the help. going out of my mind.
     
  2. jeffmc macrumors 6502

    Joined:
    Sep 21, 2007
    #2
    you should be fine after an archive and install unless it's something deeper.

    you would need your install disks to do this, or take a trip to the genius bar and they can do it for you.
     
  3. dsoreal thread starter macrumors newbie

    Joined:
    Mar 5, 2008
    #3
    thanks jeff. are the tiger os x discs generic or will I have to spend £80 to get replacement ones of mac? A friend of mine says he has some that I could use.

    Donal
     
  4. jeffmc macrumors 6502

    Joined:
    Sep 21, 2007
    #4
    it depends. if you bought just tiger alone then yes, it's more or less generic.

    if your friend has say, a mac mini

    his disks won't work on your laptop. you need something either stand alone (generic) or a set from a mac book pro specifically
     
  5. Quint macrumors member

    Joined:
    Feb 4, 2008
    #5
    Since there was no publicly available intel Tiger installer, you will have to use the discs for the MacBook Pro and specifically for whatever chipset your model uses.
    Archive install is pretty much the next to last trouble shooting step (a complete erase and install being the last one) so there are some other things you may want to try first. Try to boot into safe mode by holding down the shift key during startup. If you get a hold of an install disc, or if you have a bootable backup, you can run repair disk in Disk Utility. Also, a recent copy of Tech Tool Pro may help you out.
     
  6. nb705 macrumors newbie

    Joined:
    Jan 22, 2008
    #6
    Safe mode won't help in this case I'm afraid, an fsck may aid you, but with the master.passwd being messed up, your solution would involve either an archive and install or an erase and install.

    To perform an fsck, boot into single user mode by hold apple+s when you hear the startup chime. Then type 'fsck -fy' at the prompt and press enter.

    You will be pleased to hear that Leopard disks are generic and will work with all machines. So if (or more likely when) you need to do an archive and install, you could use one of those.

    If you're really into your command line stuff, you can probably restore the damaged files from the Darwin Kernel (although I'm unsure if the HID drivers are identical)
     
  7. dsoreal thread starter macrumors newbie

    Joined:
    Mar 5, 2008
    #7
    I tried the fsck but it didn't do anything for the problem. I am just going to have to try the archive and install in the morning. the discs that I am being given are tiger for a mac book pro. I am not sure if it will be the same chipset or anything. will have to check it out.

    my friend also has leopard discs so I might try that if the tiger ones don't work. will keep you posted. hopefully I'll be posting this from my mac tomorrow night.

    thanks for the help.
     
  8. cherry su macrumors 65816

    cherry su

    Joined:
    Feb 28, 2008
  9. ninoteca macrumors newbie

    Joined:
    Mar 10, 2011
    #9
    HELP: /private/var files deleted

    hey.
    i tried everything to getting the macbook work again - nothing helps..
    it says
    /etc/master.passwd: No such file or directory
    -sh-2.05b# IOBluetoothHCIController::start Idle Timer Stopped

    i would appreciate some help too much!!!
    thanx *
     

Share This Page