iBaba

macrumors member
Original poster
Jul 10, 2018
52
6
Using the build in screen recording app doesn't allow me to record the system audio output.

Is there any way around this?
 

harriska2

macrumors 68000
Mar 16, 2011
1,513
732
Oregon
Ooooh, didn’t know about this on a mac. On the ipad, you can manually tell it (every time) to record sound but it only records the external speaker.
 
Comment

iBaba

macrumors member
Original poster
Jul 10, 2018
52
6
You can. I do, Check in the options

No only build in mic shows up. No system sound option.

I installed sound flower extension which is supposed to do this but it's not working and can't uninstall it. Quite annoying.
 
Comment

Significant1

macrumors 65816
Dec 20, 2014
1,419
567
No only build in mic shows up. No system sound option.

I installed sound flower extension which is supposed to do this but it's not working and can't uninstall it. Quite annoying.
Soundflower does work, but you have to do a few things.
- select in the menu bar that sound out must be Soundflower (2ch)
- press shift + cmd + 5
- select video (full screen or area)
- press settings and select Soundflower (2ch) as microphone
- start recording
- after recording, switch audio back to built-in speakers before playback.

You cannot hear the sound while recording, but it can easily be solved by running "Audio MIDI Setup.app" in Utilities and create a multi-output device where you choose built-in speakers and Soundflower (2ch). Then select this as output in the menu-bar. Note that the volume keys do not work as long as the sound is output via multi-output device, so set the desired volume beforehand.
 
Comment

iBaba

macrumors member
Original poster
Jul 10, 2018
52
6
Soundflower does work, but you have to do a few things.
- select in the menu bar that sound out must be Soundflower (2ch)
- press shift + cmd + 5
- select video (full screen or area)
- press settings and select Soundflower (2ch) as microphone
- start recording
- after recording, switch audio back to built-in speakers before playback.

You cannot hear the sound while recording, but it can easily be solved by running "Audio MIDI Setup.app" in Utilities and create a multi-output device where you choose built-in speakers and Soundflower (2ch). Then select this as output in the menu-bar. Note that the volume keys do not work as long as the sound is output via multi-output device, so set the desired volume beforehand.

Excellent! thanks
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.