Mac cannot resolve some hostnames

Discussion in 'macOS' started by dbn, Jun 24, 2012.

  1. dbn macrumors newbie

    Joined:
    Jun 24, 2012
    #1
    Hi

    I've been having this problem since i reinstalled OSX on my macbook air.

    I am running OSX 10.7.4

    Whenever i try to ping my pc (named danni-pc) from my mac:apple: i get this error:

    Same result with 'danni-pc.local'

    If i ping my linux server, "digis", it works fine-ish - i have to put .local at the end of the hostname for it to work, but i guess i can live with that:

    The mac:apple: can ping itself by using 'danniair.local'.

    I can ping danni-pc from my server (digis) and the other way around without any problems.

    I can also ping the mac:apple: (danniair) from danni-pc.

    If I use IP-adresses instead of hostnames it works fine in all cases.


    I have tried to enable windows sharing on the mac:apple: under 'Sharing', and checked the "Share files and folders using SMB (Windows)" box.

    When I go to network settings on the mac:apple:, it states that it is connected to my wireless network and has the ip 10.0.0.149.

    I don't know what to try next. Any help would be greatly appreciated!
     
  2. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #2
    No promises, but something to try...

    System Preferences->Network->Advanced->WINS tab

    Set the workgroup to match your PC's workgroup.
     
  3. dbn thread starter macrumors newbie

    Joined:
    Jun 24, 2012
    #3
    No luck..
     

Share This Page