Mac causes internet to slow?

Discussion in 'OS X Mountain Lion (10.8)' started by Jules=3, Aug 18, 2012.

  1. Jules=3 macrumors newbie

    Joined:
    Aug 18, 2012
    #1
    Lately, our internet has been really slow, and my Mac is causing it. When I get on Wi-Fi, it's really fast for the first few minutes, then gradually gets slower, as does everyone else's wi-fi for their computers or iPhones. We've replaced our modem and router, but that's it.

    MacBook Pro OS X 10.8
    15 inch
    2 GHz Intel Core i7 processor
    4 GB 1333 MHz DDR3 memory

    Oh, and I kind of guessed what information you guys need. Just say the word if it isn't enough. I'm a newb here. :)
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
  3. sashaki macrumors newbie

    Joined:
    Sep 2, 2012
    #3
    YES works! (I think)

    Changing the DNS settings (as recommended - as follows) has restored my laptop to my network's internet speed potential, THANK YOU.

    In fact, I was so pleased with the result that I went through the annoying process of registering for macrumors, confirming the email, and proving I was a human. It did stop working again a few minutes later. Then I adjusted form OpenDNS to Google, then back, restarting computer, etc. I finally reentered OpenDNS settings a second time, and since then it has been working fine.

    My specs: new standard-issue Macbook, latest OS version with all regular updates. Wild fluctuations in wifi speed over two generally excellent-speed networks (home and work) where others' computers and my old PC operate perfectly fast.

    Solution Source: http://guides.macrumors.com/Mac_Virus/Malware_FAQ

    1. Go to System Preferences > Network
    2. There you will see a padlock icon in the lower left corner. If the padlock is already open (unlocked), go directly to step 3. If the padlock is closed and the note says "Click the lock to make changes", click the lock and enter your administrator password, so you can change DNS servers.
    3. Select your network on the left column, click the "Advanced" button in the lower right area of the window.
    4. Click the DNS tab to see the listing of your DNS Servers
    5. If any of the DNS servers are greyed out after entering your admin password, you may be able to simply add the OpenDNS or Google servers listed below. If you need to remove greyed-out servers, refer to this: 10.5: Disable DHCP-specified DNS servers
    6. Select each set of numbers and click the "-" icon for each to remove all existing DNS servers
    7. Click the "+" icon to add the following servers.
    You may choose either OpenDNS or Google servers (not both sets):
    OpenDNS (OpenDNS has announced they are blocking the Flashback trojan):
    Primary DNS Server: 208.67.222.222
    Secondary DNS Server: 208.67.220.220
    Google:
    Primary DNS Server: 8.8.8.8
    Secondary DNS Server: 8.8.4.4
    8. When you've completed your changes, click "OK" to close the Advanced settings window
    9. Click "Apply" on the Network window to save your changes
     
  4. Jenni8 macrumors member

    Joined:
    Apr 27, 2011
    Location:
    CA
    #4
    Worked for me too!

    I was having issues with my internet just the same and the above solution worked for me like gold.

    I was thinking it was the SP as we have had other issues other than internet.

    I'm so grateful its working properly again or maybe better.

    Thanks!
     

Share This Page