Mac connected to router but not the internet

Discussion in 'MacBook Pro' started by futuresex, Jun 17, 2011.

  1. futuresex macrumors newbie

    Joined:
    Jun 17, 2011
    #1
    I recently moved from the US to Spain, and i tried connecting to the wireless internet here, but it doesn't work. I have full bars with the router, but I still cant access the internet. Everyone in my host family can access the internet. My ip address is 169,254,55.206 and my subnet mask is 255.255.0.0. Any help would be greatly appreciated!
     
  2. Peteman100 macrumors 6502

    Joined:
    Apr 28, 2011
    Location:
    Berkeley, CA
    #2
    Do they use mac address filtering?
     
  3. harcosparky macrumors 68020

    Joined:
    Jan 14, 2008
    #3
    If you computer is the only one that cannot see the net, check the IP of the others.

    You IP address, does not look right. I bet the others have IP addresses that be look like this ..... 192.168.0.X

    If you can manually set an IP you might be able to force one like all the others but you need to know what all IP's are.

    So if the others are like

    192.168.000.102
    192.168.000.103
    192.168.000.104
    192.168.000.105

    Of course if there is a hardware problem with your system setting a IP address manually may not get you there either.


    Turning off the ROUTER and disconnecting power to force a complete RESET might help as well.
     
  4. lmtorres macrumors newbie

    Joined:
    Jun 17, 2011
    #4
    Ugh. I also recently made move from the US to Spain.

    My fix:
    Reset Safari (Safari>Reset Safari>Make sure all boxes are marked and click)
    Restart computer.

    If possible, restart the router. Good luck
     
  5. MacsOnAnabolics macrumors regular

    MacsOnAnabolics

    Joined:
    Jul 31, 2009
    Location:
    Rancho Cucamonga, CA
    #5
    Call your ISP. One of their technicians should be able to correct the problem.
     
  6. ratzzo macrumors 6502a

    ratzzo

    Joined:
    Apr 20, 2011
    Location:
    Madrid
    #6
    Try this.

    System Preferences > Network > Advanced > TCP/IP

    Configure IPv4: Using DHCP
    Configure IPv6: Automatically

    What this does is, connect to your router via DHCP (provided your router has this option active, which 90% do with factory settings). And what this means is, in essence, that you get an automatically assigned IP without having to do anything. That 169.xx.xx.xx IP you mentioned sounds pretty strange. After you do this, close Sys Prefs, disable AirPort and connect to your network again, see how it goes.
     
  7. ratzzo macrumors 6502a

    ratzzo

    Joined:
    Apr 20, 2011
    Location:
    Madrid
    #7
    Well, the OP did mention other people in the household can connect no problems. So it all points at his Mac being the one out of tune here, I doubt force resetting the router might help.


    Well, ultimately the problem lies within the fact that while he can connect to the WiFi SSID, he just has no connectivity. So Safari has no play here, since it can't even access the internet to begin with. The problem lies within his network configuration.


    Probably the best idea, it's always easier to guide someone over the phone. A couple years back I remember calling my Spanish ISP (Telefonica, now Movistar) and they didn't offer any help to Mac users though :confused: hopefully that's all changed now with the Apple revolution :p
     
  8. futuresex thread starter macrumors newbie

    Joined:
    Jun 17, 2011
    #8
    Thanks for all the help guys! I'm going to try to put in the IP manually once my host family wakes up. Hopefully I can thank you all on my own computer in a couple of hours!
     
  9. bigjobby macrumors 65816

    Joined:
    Apr 7, 2010
    Location:
    London, UK
    #9
    I would try reserving an IP on the router for your MBP. The funky address you have is probably due to your MBP not playing ball with the Belkin's DHCP and thus the MBP assigns itself a standard local address.

    Worth a shot.
     
  10. futuresex thread starter macrumors newbie

    Joined:
    Jun 17, 2011
    #10
    Update: Forcing the ip didn't solve the problem although the airport circle is now green and not orange... Also, I am able to go on the internet at other places with my laptop, just not at home :(

    My host dad already called the ISP, and they basically told him to do it himself.



    I don't think this is something I can do easily since I'm a bit computer illiterate, in fact I have no idea what this means.
     

Share This Page