Mac Contacts are not syncing with iCloud

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by jwolf6589, Oct 13, 2012.

  1. jwolf6589 macrumors 65816


    Dec 15, 2010

    Following the advice in the article DID NOT resolve my syncing issues with the contacts app. Contacts that I create on the Mac DO NOT sync to iCloud or my iOS device. However contacts created on my iOS device or iCloud DO SYNC to my Mac. I have done the following which HAS NOT resolved my issue.

    1) Systems prefs ---> iCloud
    2) Disabled and enabled Contacts
    3) Rebooted

    Is there anything else I can try?

    Also I am still getting duplicates in my contacts and I am having to manually delete a number of entries even after following the advice in this article which cleared about 80 of my duplicates but thats all.

    Thank you for your help

    iPhone 4S, OS X Mountain Lion (10.8.2)
  2. HazyCloud, Oct 19, 2012
    Last edited: Oct 19, 2012

    HazyCloud macrumors 68030


    Jun 30, 2010
    Open Contacts on your Mac. Go to Preferences>Account. Make sure 'Enable this account' is checked under iCloud.

    If that is, make sure under Preferences>General that the Default Account is set to iCloud, not On My Mac. You may be set to your Mac and that's why they aren't syncing.
  3. HE Chas macrumors newbie

    May 23, 2008
    Lakewood CO
    I did the things you noted. I am still not getting the contacts entered on my Mac to synch with iCloud. Help?!
  4. sculpher macrumors newbie


    Oct 11, 2011
    Dallas, Texas
    I am seeing exactly the same symptoms on my Mac (Mountain Lion)
  5. rogerthat macrumors member

    Jun 14, 2007
    --- Post Merged, Jun 23, 2017 ---
    I found that I have 2 different iCloud accounts on my Mac Contacts...when I just hit the + to add a contact and the "all contacts" group is selected, the contact does not go to my iCloud account. If I simply drag the new contact to my iCloud account name in the groups list, it will immediately show up in the cloud and on my iOS devices...does not make an annoying duplicate either.

Share This Page