Mac converts text files to a Word document

Lynne326

macrumors member
Original poster
Jun 25, 2011
49
3
Hello everyone,

Does anyone know how to stop Mac from converting a text file to a Word document? It's only on one text file and I can't figure out why it happens. I've recreated the file a few times in Textedit and it's ok for awhile and then suddenly opens in Word.

Thank you!
Lynne
 

SoyCapitanSoyCapitan

macrumors 601
Jul 4, 2015
4,484
2,497
Paris
Hello everyone,

Does anyone know how to stop Mac from converting a text file to a Word document? It's only on one text file and I can't figure out why it happens. I've recreated the file a few times in Textedit and it's ok for awhile and then suddenly opens in Word.

Thank you!
Lynne
TextEdit creates RTF or TXT files. You can choose which when saving.

The reason it is opening in Word is because RTF files on your computer are associated with Word.

On your txt or rtf file right click and choose Get Info. You will see an ‘Open with’ option. Choose TextEdit and then click Change All.

Now all txt or rtf files will open with TextEdit.

http://osxdaily.com/2013/08/08/change-default-application-open-files-mac-os-x/
 

dwig

macrumors 6502a
Jan 4, 2015
650
238
Key West FL
TextEdit creates RTF or TXT files. You can choose which when saving. .../
... but ...
TXT files do not support any text attributes. If you start with a TXT file and then opt to "Make Rich Text" so you can set a font, bold, italic, ... you can only save it as RTF. To save as TXT again, you have to opt to "Make Plain Text", which will remove all text formatting other than carrige returns.
 

Lynne326

macrumors member
Original poster
Jun 25, 2011
49
3
... but ...
TXT files do not support any text attributes. If you start with a TXT file and then opt to "Make Rich Text" so you can set a font, bold, italic, ... you can only save it as RTF. To save as TXT again, you have to opt to "Make Plain Text", which will remove all text formatting other than carrige returns.
[doublepost=1543263695][/doublepost]Good to know, thank you dwig!