Mac does not autoconnect to wifi network

Discussion in 'macOS' started by HurricaneDC, Jun 19, 2009.

  1. HurricaneDC macrumors newbie

    Joined:
    May 15, 2009
    #1
    For some reason, my mother's MacBook Pro doesn't automatically connect to our home's wireless network. It's encrypted with WPA2. My MBP and my sister's MacBook stay connected fine. My mother's, however, requires her to click on the AirPort icon at the top and select our network each time she wakes it or boots it up. This only started happening when I put WPA2 on the network. How do I fix this?
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    Make sure in System Preferences > Network > Airport > Advanced > Airport, that the "Remember any network this computer has joined" is checked and that "Disconnect from wireless networks when logging out" is unchecked.
     
  3. jamisonprawn macrumors newbie

    Joined:
    Jul 12, 2008
    #3
    My Macbook is doing exactly the same thing. Any WPA2 protected network, it won't auto-connect to it on wake (or boot up).

    It connects for about 3-5 seconds, and then drops the connection and pops up the window saying "none of your preferred networks are available"... and there's my network in the list to click and connect to with no problems.

    Any other advice from anyone would be appreciated... I've had this issue for about 4 months now and even Apple Geniuses can't solve it!!
     
  4. jimmie48jj macrumors newbie

    Joined:
    Jun 24, 2009
    #4
    I am having this problem with mac os lion with my macbook pro. it was working before i updated to lion. Iv tried changing every setting, deleting the networks, everything i can think of. any ideas ?
     

Share This Page