Mac drive not mounting, need to access the files, possible partition table issue?

Discussion in 'OS X El Capitan (10.11)' started by SanMed1, Feb 11, 2016.

  1. SanMed1 macrumors newbie

    Joined:
    Feb 11, 2016
    #1
    Hi there!

    Short version is I am trying to recover files / OS install from a mac hard drive that won't mount (but does spin up and show both partitions in disk utility).

    Long version - I swapped out the internal hard drive for an SSD and planned to use a fresh install of latest OS X and copy the old files over as they were needed. The hard drive is in a USB enclosure and has 2 partitions, but the internal hard drive stopped mounting at some point after the swap.. I do think it worked originally and I already tried a different enclosure. I tried Migration Assistant and Time Machine to restore the files but neither will restore my 2nd partition and also the software doesn't work due to it being a fresh install (I can't reinstall these programs as they're volume licensed).

    Mac Mini 2010
    OS X El Capitan (but I updated from I think Mountain Lion).
    750GB ish hard drive, 2 partitions (was mac boot drive)
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
  3. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #3
    Drive plugged straight into mac, no hubs?
    I've had some trouble w those.
     
  4. SanMed1 thread starter macrumors newbie

    Joined:
    Feb 11, 2016
    #4
    Have tried using disk warrior but none of my external drives are showing up as option, but they show up fine in disk utility (although i can't do anything with the problematic drive in DU). any ideas? not using any hubs either.
     
  5. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #5
    Do you have a DIFFERENT Mac with which you could try the problem drive?

    Get the same results?
     
  6. Gochugogi macrumors regular

    Gochugogi

    Joined:
    Oct 27, 2013
    Location:
    Sandwich Isles
    #6
    Same here. Tossed the hubs and everything just worked...
     

Share This Page