Mac Freezes after sleep with 10.5.1

Discussion in 'macOS' started by Europe calling, Dec 1, 2007.

  1. Europe calling macrumors regular

    Europe calling

    Joined:
    Jun 27, 2007
    Location:
    The Netherlands
    #1
    I have problems with a freezing computer since i updated to 10.5.1.

    My Mac has become very unstable. When it has been unused for a while it does'nt awake from sleep and i have to do a forced restart. I don't dare to leave work unsaved before i leave my Mac anymore, because i know i will otherwise lose it! :mad:
    This never occurred with 10.5.0.
    There must be some kind of bug. I get the impression it might be bluetooth related. I use a Logitech bluetooth mouse. I am now back to my wired mouse to see if this resolves the problem.

    Mac Pro 2.66Ghz Dual w. NVIDIA GeForce 7300 GT, 3 Gig RAM, OSX 10.5.1
     
  2. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #2
    Sorry to bring this back from the dead. But did you find a solution? Are you running hardware monitor by any chance?
     
  3. Europe calling thread starter macrumors regular

    Europe calling

    Joined:
    Jun 27, 2007
    Location:
    The Netherlands
    #3
  4. Wallace25 macrumors member

    Wallace25

    Joined:
    Feb 21, 2007
    #4
    I dont think it has anything to due with bluetooth because this has happened to me with 10.5.1 and I dont have any bluetooth things hooked up.
     
  5. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #5
    Ok thats different then mine then, as mine doesn't leave any trace in any log file. And you can still SSH into the machine. You just can't move the mouse or anything. :eek:
     
  6. billmister macrumors 6502

    Joined:
    Sep 15, 2007
    #6
    what was the things you installed after installing leopard. Maybe the application is not compatible with leopard that is what is giving you the problems. I run Leopard on my imac and my comptuer runs just fine. Sleeps, shuts off, restarts, all great. I doubt is the Os. Maybe a external hard drive is causin this problem as well.
     
  7. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
  8. theman macrumors 6502a

    Joined:
    Jul 26, 2007
    #8
    i used to get this a lot, but it stopped happening after I stopped closing my mbp (i don't bring it around much). it seems to be really unstable after opening the lid to wake it. if you just let it fall asleep with the lid open, there's no problems. i have gotten kernel panics when i plug in usb devices right after opening the lid too.
     
  9. godspeed macrumors member

    Joined:
    Apr 8, 2006
    #9
    I experience the same problem on my imac 2.8. After trying to wake it from sleep I'm faced with a continuous spinning wheel....
     
  10. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #10
    I never get the spinning wheel thats different.
     
  11. callmemike20 macrumors 6502a

    callmemike20

    Joined:
    Aug 21, 2007
    Location:
    USA
    #11
    I actually have the sleep issue as well. I just went to the apple store here in Chicago and the Genius Bar guy did an archive and install of leopard. It's been about 26 hours, and I have not had the issue since. (Knock on wood).
     
  12. gvg45 macrumors member

    Joined:
    Aug 22, 2007
    Location:
    Los Angeles, Ca.
    #12
    I had the exact same problem when I updated my 2.8 iMac from Tiger to Leopard. When it went to sleep it never woke up. I ended up reloading Tiger and had been using that for a while. I finally had enough time to get an appointment at the Genius Bar and it was found that the video card had to be replaced.
     
  13. theloon macrumors member

    theloon

    Joined:
    Dec 19, 2007
    #13
    Potential fix for the this keyboard/wake from sleep bull.

    I seem to have found a fix that is working for me.

    I have the same problems as others on this thread.

    So I have disabled the wake on lid open function, and use a keyboard press once the lid is open.

    sudo pmset lidwake 0

    This has worked now for 3 days, close lid, wait for it to sleep, and open it later, seems ok now.

    pmset has changed a lot, with new hibernation technics - which seems to have broken a few things.

    Hope this works for others too.
     
  14. TheMacPotato macrumors member

    Joined:
    Mar 3, 2006
    Location:
    London
    #14
    I don't know if my problem is related, but I get similar on My new imac 20inch (running 10.5.1). After waking up from a sleep the Bluetooth mighty mouse initially works, but then after a few seconds it freezes. The Keyboard (wired USB) still works and using that I navigate to the Sys prefs for bluetooth and see that my mouse is still seen, but just not responding. restarting the machine cause the mac to stick on the shut down spinning wheel thing in the centre of the screen (it keeps going round but nothing happens). The only way to restart it is to force it with the power button. upon starting up again it is fine.

    This happens practically every time after the iMac goes to sleep. I've tried resetting my PRAM. any other ideas anyone?
     
  15. theloon macrumors member

    theloon

    Joined:
    Dec 19, 2007
    #15
    TheMacPotato - imac wake sleep problem

    Hi TheMacPotato - can you post the entries in the system log, so we can see what happens when it wakes from hibernation. If you check the time stamps in the log post the ones from when you wake the machine.

    It is this directory, you can get to it using the terminal application.

    /var/log/system.log

    Cheers
     
  16. tsaxer macrumors regular

    Joined:
    Feb 24, 2004
    Location:
    Tuscaloosa, AL
    #16
    I'm having a similar issue. When I open my MBP, my display does not wake up, even though I think the system is awake. Sometimes if I close and open the book, the display will wake, but not often. I've done a clean install and it still does it.
     
  17. TheMacPotato macrumors member

    Joined:
    Mar 3, 2006
    Location:
    London
    #17
    Thanks, but when i type that command i get the reply:
    "/var/log/system.log: Permission denied."
    even when logged in as root!
     
  18. TheMacPotato macrumors member

    Joined:
    Mar 3, 2006
    Location:
    London
    #18
    OK i found the logs using Console, This is the part from when my iMac went to sleep last night and then woke up a few hours later:

    26/01/2008 7:47:40 pm kernel hibernate image path: /var/vm/sleepimage
    26/01/2008 7:47:40 pm kernel sizeof(IOHibernateImageHeader) == 512
    26/01/2008 7:47:40 pm kernel Opened file /var/vm/sleepimage, size 2147483648, partition base 0xc805000, maxio 400000
    26/01/2008 7:47:40 pm kernel hibernate image major 14, minor 2, blocksize 512, pollers 4
    26/01/2008 7:47:40 pm kernel hibernate_alloc_pages flags 00000000, gobbling 0 pages
    26/01/2008 7:47:41 pm kernel System SafeSleep
    27/01/2008 12:15:34 am kernel hibernate_page_list_setall start
    27/01/2008 12:15:34 am kernel hibernate_page_list_setall time: 96 ms
    27/01/2008 12:15:29 am /System/Library/Frameworks/ApplicationServices.framework/Frameworks/ATS.framework/Support/ATSServer[95] ATSFindFolder timeout. (domain:-32763, dirType:'font', createFolder:false, ATSServer pid:95)
    27/01/2008 12:15:34 am kernel pages 266010, wire 88510, act 103346, inact 30, zf 0, throt 1805, could discard act 31971 inact 29042 purgeable 11306
    27/01/2008 12:15:34 am kernel hibernate_page_list_setall found pageCount 193691
    27/01/2008 12:15:34 am kernel IOHibernatePollerOpen, ml_get_interrupts_enabled 0
    27/01/2008 12:15:34 am kernel IOHibernatePollerOpen(0)
    27/01/2008 12:15:34 am kernel writing 192732 pages
    27/01/2008 12:15:34 am kernel image1Size 232039936
    27/01/2008 12:15:34 am kernel all time: 6397 ms, comp time: 1211 ms, deco time: 0 ms,
    27/01/2008 12:15:34 am kernel image 493878784, uncompressed 789430272 (192732), compressed 489252604 (61%), sum1 53b84bfe, sum2 bd3c391a
    27/01/2008 12:15:34 am kernel hibernate_write_image done(0)
    27/01/2008 12:15:34 am kernel sleep
    27/01/2008 12:15:34 am kernel System Wake
    27/01/2008 12:15:34 am kernel AppleYukon2: 00000000,00000000 sk98osx_dnet - recovering from missed interrupt
    27/01/2008 12:15:37 am kernel AppleUSBHub::setPowerState(0x448e200, 2 -> 4) timed out after 10428 ms
    27/01/2008 12:15:37 am kernel EIR is not supported.
    27/01/2008 12:15:37 am kernel SetCryptoKey T: len 16, idx 0
    27/01/2008 12:15:37 am kernel SetCryptoKey R: len 16, idx 3
    27/01/2008 12:15:40 am kernel AppleYukon2: 00000000,00000000 sk98osx_dnet - recovering from missed interrupt
    27/01/2008 12:16:57 am kernel BT_USB Controller: SuspendDevice(0) failed with error e0004051
    27/01/2008 12:16:57 am kernel BT_USB Controller: SuspendDevice(0) we are still connected to our hub so .. plain reset 0x44b1100
    27/01/2008 12:17:37 am kernel CSRUSBBluetoothHCIController::setPowerState(0x44f2c00, 1 -> 2) timed out after 60184 ms


    Hope this makes sense. Thanks for your help on this, much appreciated :)
     
  19. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #19
    It looks like safesleep is turned on. You could try disabling it and see if that solves your problem.
     
  20. iCeFuSiOn macrumors 6502a

    Joined:
    Jul 18, 2007
    #20
    To narrow it down, here's what sticks out to me as what may be the cause of the problem.

     
  21. vig1116 macrumors newbie

    Joined:
    Feb 17, 2008
    #21
    Might Be Usb

    i was having similar problems like some of you guys about freezing after coming out of wake from my 24in imac..... the first solution was i changed the option to not turn off hard disk back to default. it is better to shut off hard disk during sleep(unless a program requires it to stay awake) the second solution was, and i am shocked and need to call apple to see what can be done is...... i unplugged all 3 of my USB cables from the back of the imac!!!!!! WTF???? why would this be interfering with the comp??? anyway, the usb cables i had were not being used all the time, only when i D/L images from camera etc..... but now thet i unplugged them my comp is faster than ever when it awakes my mouse pointer is on instantly(which it never did before) and i can actually hear the hard disk start up when it is in sleep and i hit the space bar, thats how i know is was def sleeping. i really hope this helps some of you cause it took me 3 weeks to figure it out and i was on the phone with applecare for like 7 hrs all together over the past 3 weeks. and every time i called them they made me do the same thing over and over again....... let me know if this helps anyone, and if anyone knows y it is happening so i can plug my cables back in.
     
  22. tcfoto macrumors newbie

    Joined:
    Feb 28, 2008
    #22
    usb cables causing freeze also?

    I may have the same or similar problem. Mac Pro 2.8 quad Leopard 10.5.2 Bluetooth Mighty Mouse. When nothing is plugged in besides keyboard it wakes from sleep perfectly. When I leave usb cables attached (printer, wacom tablet, scanner) mouse freezes upon wake up after a minute or two and system preferences will freeze if I try to access it.
     
  23. vig1116 macrumors newbie

    Joined:
    Feb 17, 2008
    #23
    figured out mine.....

    ok my problem was the printer through USB i had to update my drivers through the manufacturers website and it worked like a charm. actually my imac works better than ever, as soon as it wakes my mouse is ready with no delay like it used to so im happier than a pig in ..... well u know lol do a trial and error procedure like i did. i put my slep times down to 1 min all around and then i plugged in 1 usb at a time and if it went to sleep and woke fine then i moved on..... when i got to the printer i found the problem.... hope this helps
     
  24. alesha macrumors newbie

    Joined:
    Mar 5, 2008
    #24
    it fixed it

    If you don't know how to execute this command:

    Open a terminal session (Applications>>Utilities>>Terminal)
    type the above command
    you should be prompted for a password
    enter it
    hit return

    tada!

    thanks loon.
     
  25. vig1116 macrumors newbie

    Joined:
    Feb 17, 2008
    #25
    just so you guys know what "sudo pmset lidwake 0" does, it makes it that if you have a macbook(laptop) it wont wake from sleep if you open the cover. so before you change pmset settings make sure thats what you want to do. i had a totally different problem from that cause i have an IMAC not macbook.....
     

Share This Page