.Mac Gallery bug

Discussion in 'macOS' started by TuffLuffJimmy, Aug 16, 2007.

  1. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #1
    I am currently running the new safari 3 beta, but I usually prefer to steer clear of betas. The reason I am using it is because the regular version of safari doesn't display the .Mac web galleries correctly. It has no skimming feature when I first visit the iPhoto '08 published galleries. But after I enter the gallery the skimming feature works, but only for galleries I have entered. After I close that gallery, and then later revisit it the skimming feature is lost again. However in the beta of safari the feature works fine, I have searched for this on Apple's support forums and have found other people who have encountered this same problem, and my friend with the same computer as me (black macbook 2.0GHz Core2Duo) is also experiencing the same problem. Does this feature simply not work in Safari? Is this because the skimming will only be a feature of leopard? Any help or information would be greatly appreciated.
     
  2. brianus macrumors 6502

    Joined:
    Jun 17, 2005
    #2
    This is a real and seriously lame bug (feature?) of the .Mac web galleries. They do NOT work correctly in Safari 2, and I've tried it on 3 different machines (a G4, a G5 and a Xeon). Funny, because if you try it in Camino, you'll get a warning saying you should really use a different browser, but it works just fine in Camino. Safari 2 just fails without explanation! I've tried it in Safari 3, and it doesn't seem 'enhanced' in any way; it works the same as it does in Camino. So I don't think it takes advantage of any Leopard features.

    Which stands to reason, since 'skimming' is a very simple bit of Javascript which certainly *should* work in any browser. We have a proprietary web gallery system where I work, and I was able to implement skimming in it within an hour of seeing the iPhoto '08 demo.
     

Share This Page