Mac goes to sleep with iTunes still playing?!

sebf

macrumors member
Original poster
Oct 25, 2006
48
0
UK
Hi,

I have had my Mac Mini for about 2 days and I am just getting used to it all as I have been a long time Windows user.

Is there any way of preventing my Mac from going to sleep while its still playing? (possibly without disabling the sleep mode) As its a bit annoying having to wake my Mac up again to continue play back.

Thanks for any help!
 

matthew24

macrumors 6502
May 30, 2002
388
0
Netherlands
Does not happen to my G5 Powermac! (just tested)

Maybe there is a software / hardware issue (bug!) on the OS X / Intel platform.

I would post it at Apple's discussion-board as well.
 

sebf

macrumors member
Original poster
Oct 25, 2006
48
0
UK
I have set the display to automatically turn off after 10 minutes and disabled it from sleeping plus the sleeping hard drive option is disabled.

But even the when it puts the monitor on standby iTunes stops playing, which seems quite bizarre as the mac should still be running.

Heres a screen grab:
 

Attachments

bitabytex

macrumors member
Oct 26, 2006
38
0
That is an odd reaction. I also have a Mac Mini (ppc), but it doesn't go to sleep when music is playing. When I put the monitor to sleep with the music playing, it still plays fine. Did you by chance install anything like plugins or other apps that would create some type of functionality for sleep or iTunes?

Also, I would contact Apple to see if they can figure it out.
 

MrSmith

macrumors 68040
Nov 27, 2003
3,046
14
Your settings in Energy Saver shouldn't stop iTunes. Does it stop in the middle of a song or at the end of a song? Are you sure you're using iTunes properly? Is it stopping at the end of a playlist or something? Don't mean to insult your intelligence, only you said you've had 2 days' experience.
 

04440

macrumors member
Oct 26, 2006
97
0
Los Angeles
MrSmith said:
Your settings in Energy Saver shouldn't stop iTunes. Does it stop in the middle of a song or at the end of a song? Are you sure you're using iTunes properly? Is it stopping at the end of a playlist or something? Don't mean to insult your intelligence, only you said you've had 2 days' experience.

Ha That's awesome.. ha No insults.. Yeah.. that seems a little weird why it's going to sleep
 

MrSmith

macrumors 68040
Nov 27, 2003
3,046
14
04440 said:
Ha That's awesome.. ha No insults.. Yeah.. that seems a little weird why it's going to sleep
Huh? Did I say something stupid? I was addressing the OP as a complete newbie. Hell, we all made stupid, obvious mistakes within our first two days.
 

Avenger23

macrumors regular
Dec 28, 2001
150
0
Clovis, NM
sebf,
I would try going to the Energy Saver control panel in the System Preferences area and click the Show Details button in the bottom left corner and select Custom in the Optimization drop down menu.

Then move the slider for "Put the computer to sleep when it is inactive for:" to Never and move the slider to "Put the display to sleep when the computer is inactive for:" wherever you want it to turn the display off.

This should let the display sleep and your music should stay running... if this is what you're looking for... if not just move the sliders to never, then you don't ever have to worry about the Mac/display going to sleep... I think this is what others were trying to mention but if not give it a shot...

Hope this might help... :)

Avenger23
 

bitabytex

macrumors member
Oct 26, 2006
38
0
Avenger23 said:
This should let the display sleep and your music should stay running... if this is what you're looking for... if not just move the sliders to never, then you don't ever have to worry about the Mac/display going to sleep... I think this is what others were trying to mention but if not give it a shot..
NOT turning them off is what he wants. And when I DON'T turn them off, iTunes still plays fine and doesn't go to sleep when music is playing. So this shouldn't be an issue.
 

sebf

macrumors member
Original poster
Oct 25, 2006
48
0
UK
I have tried load of different ways of setting the Energy Saver, but the only solution I have found is to turn everything off, even when I set "Put the display to sleep when the computer is inactive for" 1 minute it will still stop iTunes playback.

I haven't installed any iTunes plug ins, the only plug that iTunes could be using is an AC3 playback codec, Perian (which is for playing back DivX, XviD, FLV, and AVI) and a Dashboard iTunes lyrics finder, I can't think of anything else that would be affecting it. :confused: Also it does this in the middle of a track and not at the start or end of it. When I wake it back up again it starts playing again.

I would like to use the display off or even the sleep modes as I do some times leave my computer running for along time and it seems a bit odd to keep it on all the time.
 

amiga

macrumors 6502
Jul 12, 2006
354
0
London.
Maybe you should speak to Apple? I think if you use the iTunes visualiser it keeps the computer awake if that help :) Could be a short term fix.
 

sebf

macrumors member
Original poster
Oct 25, 2006
48
0
UK
amiga said:
Maybe you should speak to Apple?
Well it was a bit odd calling them over such a small problem, they just said that you need to change "Put the computer to sleep when it is inactive for" to Never and untick "Put the hard disk(s) to sleep when possible" as those are the only 2 options that would course it to stop play back.

Which is what I have already done, but yet even with those options set it will still stop audio play back, seems abit odd. He also suggested creating another account and test it on there which I did and just added an MP3 into it let it play for a minute and sure enough the screen went off and along with the music, heres another screenshot of my test settings.

All my music is on my external USB drive I copied it across to my Mac to see if it would make any difference, but no luck there.

I guess the only option is to turn all energy settings off, which isn't great.:(
 

Attachments

Avenger23

macrumors regular
Dec 28, 2001
150
0
Clovis, NM
bitabytex said:
NOT turning them off is what he wants. And when I DON'T turn them off, iTunes still plays fine and doesn't go to sleep when music is playing. So this shouldn't be an issue.

I was just throwing that out there... :(
 

sebf

macrumors member
Original poster
Oct 25, 2006
48
0
UK
I have found a solution to this problem! :rolleyes:

Install Jiggler and configure it so that it moves the mouse every 5 mins for you only when iTunes is in play back mode.

Seems abit strange having to use a 3rd party program to do something Mac OS 10.4.8 should have done out of the box for you!
 

Gangzztar

macrumors newbie
Apr 21, 2011
1
0
You can't because when you leave something on while sleeping it heats your computer and burn your motor
:apple:
 
Last edited:

amygdala99

macrumors newbie
Jan 15, 2012
1
0
going to sleep still a problem in 2011 : (

I have a new iMac bought within the year, and it is doing this. We have the settings as suggested here, go to sleep:Never, and have unticked putting the hard disk to sleep.
NEW IDEAS for the new decade???
 

tareyton

macrumors newbie
Jan 16, 2012
1
0
Same problem for me.

Using OSX 10.5.8

When playing itunes via airplay to a pioneer receiver itunes will stop when the screen goes to sleep. The only way I can prevent this is if I set screen to NEVER sleep. Hardrive is also set to never sleep.

On a separate note Time Machine will not work (using a seagate goflex home drive) if the screen is allowed to sleep. It is almost like when the screen sleeps it hibernates the computer. It is not just sleeping the screen.

If anyone knows of any fixes or workarounds I would appreciate it.
 

krause734

macrumors 6502a
Jul 30, 2010
592
1,404
Try Control + Shift + Eject to turn the display off and keep iTunes running. If you want to keep your computer on indefinitely, try using a program called caffeine. It's very easy to use.
 

cristiano.gato

macrumors newbie
May 4, 2012
1
0
Speakers built-in with monitor

I had the same issue after a while searching google and not finding an answer I finally realize the dumb mistake. My speakers are built-in with the monitor, so when the screen is turn-off, so are the speakers.
 

kindleboy

macrumors newbie
May 4, 2016
1
0
Speakers built-in with monitor

I had the same issue after a while searching google and not finding an answer I finally realize the dumb mistake. My speakers are built-in with the monitor, so when the screen is turn-off, so are the speakers.
I have a MBP w/ Retina display and I have the same issue; after about 1 hour of streaming itunes via AirPlay, my MBP will close all open applications and go into a "sleep like mode". This is not the same as the sleep function as in this case my MBP closes all open apps. I have played around with all the energy saver settings and nothing has any impact on this. Any thoughts?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.