Mac hangs at boot .. unmounted HDD?

Discussion in 'Mac Basics and Help' started by calcalcal, Jun 11, 2008.

  1. calcalcal macrumors newbie

    Joined:
    Jun 11, 2008
    #1
    hey folks

    the other day i was mucking around on my macbook (10.5, 2 gigs of ram, 2.4)
    and i realised that in finder/pathfinder that my one and only harddrive's
    eject button was missing... i dont konw wat caused this as my mac has been
    continually been on for a few days.. (using sleep instead of shutdown)
    but after noticing this i tried to install a few dmgs : "no mountable file systems"

    so i tried to reboot and but it just hangs on the grey screen with the initial spinning wheel... im quite new to mac so i dont konw how to boot up with the
    disc and do stuff like that..

    but i did read on another thread to boot with ctrl S and then type in /sbin/fsck -fy
    it said the hdd was ok .. i just think i need to mount it again??????

    or is that just crazy talk ???

    any help would be much appreciated
     
  2. calcalcal thread starter macrumors newbie

    Joined:
    Jun 11, 2008
    #2
    i forgot to mention that i did try the app "disk utility" when it was on (before i rebooted) and i did repair the permissions and the hdd was all good ...
    also i tried to remount it from that program but it was grayed out and i couldnt!
     

Share This Page