Mac help (Im at wits end)

Adamscomputerrepair

macrumors 6502
Original poster
Aug 9, 2015
465
187
I had a 2009 C2D MacBook running Mojave thanks to some DosDude trickery. Unfortunately, that computer is dead and buried now. Im back to a 2008 MacBook 4,1 running snow leopard since i cant find lion or ML. Since theres no early intel thread, im turning here for help. Im running the last version of Firefox and Chrome available already but i need to know a few things. Whats the last version of FCP to run in SL? Whats the last version of Photoshop? Finally, Will office 2011 install or am i wasting my time? I have to make this laptop last a semester or i might as well drop out now. I cannot use a powerpc this time.
 

mode11

macrumors regular
Jul 14, 2015
215
95
London
I had a 2009 C2D MacBook running Mojave thanks to some DosDude trickery. Unfortunately, that computer is dead and buried now. Im back to a 2008 MacBook 4,1 running snow leopard since i cant find lion or ML. Since theres no early intel thread, im turning here for help. Im running the last version of Firefox and Chrome available already but i need to know a few things. Whats the last version of FCP to run in SL? Whats the last version of Photoshop? Finally, Will office 2011 install or am i wasting my time? I have to make this laptop last a semester or i might as well drop out now. I cannot use a powerpc this time.
Sorry if OT, but you could consider MacPostFactor: https://www.osxhackers.net/macpostfactor.html

Should let you run El Capitan (10.10) on your old Mac, though check forums to see if it will do so reliably. I believe your laptop will take 6GB RAM (2GB + 4GB), which will help. An SSD will also help a lot - any old one will do.

Most stuff will run on El Cap, though recent Adobe CCs won't.
 

Adamscomputerrepair

macrumors 6502
Original poster
Aug 9, 2015
465
187
Sorry if OT, but you could consider MacPostFactor: https://www.osxhackers.net/macpostfactor.html

Should let you run El Capitan (10.10) on your old Mac, though check forums to see if it will do so reliably. I believe your laptop will take 6GB RAM (2GB + 4GB), which will help. An SSD will also help a lot - any old one will do.

Most stuff will run on El Cap, though recent Adobe CCs won't.

I have a youtube channel dedicated to mostly unsupported Mac videos. Trust me when i say i could totally go that route if i wanted to.


But i dont want to.

If you dont have QE/CI, and are expecting to get serious work done, trust me when i say your mac becomes nothing more than a really expensive chromebook.

Id totally do a mountain lion varient if i had a copy of ML. Im not paying money for a laptop i dont intend on keeping however.
 
  • Like
Reactions: amagichnich

mode11

macrumors regular
Jul 14, 2015
215
95
London
Didn't realise no GPU acceleration - in that case I agree it's pointless. Also, forgot El C was 11.11.

Not sure what ML gets you over SL in terms of compatibility - probably not much. At least SL was a good one; never liked Lion.
 

Adamscomputerrepair

macrumors 6502
Original poster
Aug 9, 2015
465
187
Didn't realise no GPU acceleration - in that case I agree it's pointless. Also, forgot El C was 11.11.

Not sure what ML gets you over SL in terms of compatibility - probably not much. At least SL was a good one; never liked Lion.
ML supported FCP 10.0.4 Snow leopard only supports FCP 7. If i have to edit on my desktop, thats fine. Im actually copying the copy of FC i have on my powerbook right now.
 

pl1984

Suspended
Oct 31, 2017
2,230
2,603
Id totally do a mountain lion varient if i had a copy of ML. Im not paying money for a laptop i dont intend on keeping however.
Purchase it, use it, sell it. The technology you're referring to has already gone through its largest depreciation. It's unlikely it would depreciate much, it at all, in a semesters time. I just picked up a 2009 15" MBP 2.8GHz C2D, 120GB SSD, 4GB RAM for $150...shipped. I could probably turn around and sell it for the same, or slightly less, in four months.
 

swamprock

macrumors 6502a
Aug 2, 2015
874
1,078
Michigan
ML is beautiful on a Macbook4,1 with an SSD and 6gb of RAM. There are some minor graphics glitches, however, but nothing game-breaking. One thing to be aware of is that MPF 2.x doesn't install the kexts correctly for ML, so it's best to use 1.0.1 if you do end up getting ahold of ML.
 
  • Like
Reactions: Adamscomputerrepair

Adamscomputerrepair

macrumors 6502
Original poster
Aug 9, 2015
465
187
ML is beautiful on a Macbook4,1 with an SSD and 6gb of RAM. There are some minor graphics glitches, however, but nothing game-breaking. One thing to be aware of is that MPF 2.x doesn't install the kexts correctly for ML, so it's best to use 1.0.1 if you do end up getting ahold of ML.
THANK GOD FOR YOU. I HAVE TRIED MAKING THE FREAKING INSTALLER EVERY DIFFERENT WAY I COULD THINK OF
 

Adamscomputerrepair

macrumors 6502
Original poster
Aug 9, 2015
465
187
THANK GOD FOR YOU. I HAVE TRIED MAKING THE FREAKING INSTALLER EVERY DIFFERENT WAY I COULD THINK OF
Edit: Thanks to that awesome advice, it's finally finished. I found my old copies of iLife 11, Photoshop, Premiere, Office, Final Cut, you get the idea. This MacBook screams on an SSD. Note to Mods, you can mark this as resolved now. Thanks to all who helped!
 

Attachments