Mac Internal Microphone transmits a lot of background noise, help!!

Discussion in 'MacBook Pro' started by Finox831, Jul 28, 2010.

  1. Finox831 macrumors member

    Joined:
    Jul 28, 2010
    #1
    So, I'm on skype and everyone can hear all the background noise which is very annoying. I'm using the Mac book pro internal mic. Anyway to block the background noise?? and also, my headset has two plugins which is a sound/mic plug in and I noticed the mac doesn't have anywhere to plug in a mic just one for volume...
     
  2. itisme1760 macrumors 6502

    Joined:
    Oct 18, 2008
    Location:
    California
    #2
    Do you have the block ambient noise checked? This seems to help a lot, especially with the fans. If not, then you have to invest in a USB headset or something.
     
  3. Finox831 thread starter macrumors member

    Joined:
    Jul 28, 2010
    #3
    No, I don't have the block ambient noise checked...I just recently got a Mac so I wouldn't know where to find this, could you possibly direct me to it? thanks in advance.
     
  4. regieferg macrumors newbie

    Joined:
    Jul 21, 2010
    #4
    The mics on laptops are pritty strong these days. Unless you mess with the mic volume settings, i dont think there is any thing to stop it.
    i would use a plug in mic or move into a different room.
     
  5. Finox831 thread starter macrumors member

    Joined:
    Jul 28, 2010
  6. jclardy macrumors 68040

    jclardy

    Joined:
    Oct 6, 2008
    #6
    What kind of background noise are you talking about? Things like music/people talking/other constantly changing noises probably can't be blocked out. I don't use skype but the ambient noise switch may be in its preferences in the Skype menu.
     
  7. loulou3265 macrumors newbie

    Joined:
    Aug 3, 2012
    Location:
    Montreal
    #7
    How to disable the mic on a MacBook Pro (2009)

    Hi!

    To disable the mic on the MacBook Pro (I've got a later 2009 with 17" screen and use os 10.5.8), go to Applications, Utilities, AudioMidi, click in the MUTE boxes.

    It works for me!
     

Share This Page