Mac Internet Problems

Discussion in 'Mac OS X Server, Xserve, and Networking' started by SkemPab, Oct 27, 2010.

  1. SkemPab macrumors newbie

    Joined:
    Oct 27, 2010
    #1
    Hi everyone My name is Paul and Im from the UK. Im new here and new to the Mac, I work as a PC Engineer and so far have avoided the Mac because I know very little about it and have so much work just keeping up with the other OS's out there.
    Anyways I have recently had the privilege of trying to diagnose and repair a problem on a mac and it has me stumped. I was hoping for a little help from the members here if you dont mind?
    The problem reported to me was that the mac would not connect to any wireless access points. It detected the access points, asked for the password and then said it had a connection. When I tried connecting to the internet it said I didnt have an assigned IP.
    I went through many different upgrades via a LAN connection and still nothing via wireless.
    I then set the IP manually, connecting to our server and that way was able to get an internet connection. I could ping google, netstat, tracert and even ftp access worked. I also tried some news feeds built into Safari and it loaded parts of the content but not all ( makes me think it can receive rss feeds, it was like a quick surge of the feed then it stopped? ). But each time I try to connect to a web page via http it does nothing. I even tried a different browser.
    I have cleared cache, reset safari, cleared all network settings, set up as a new location and so on and still no joy.
    It boils down to I have a connection but no http access is coming through?

    I know this is long winded and appreciate any help or advice you can share. Im sorry to come here asking for help having not contributed in anyway to the forum, as I said I dont normally use Macs so Im a noob on them lol but have a good background on PC's :)

    Thanks people, hope you can help.:confused:
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    When in the Mac open System Preferences->Network and click on the 'Advanced' button since you claim you are a Personal Computer Engineer. In the the 'Advanced' menu make sure you are getting the server's DNS or manually put in the DNS.

    Plus make sure the wireless Access Point allows the MAC Address (not Mac) of the Mac.
     

Share This Page